summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/blogc-runserver/blogc-runserver-9999.ebuild')
-rw-r--r--www-servers/blogc-runserver/blogc-runserver-9999.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/www-servers/blogc-runserver/blogc-runserver-9999.ebuild b/www-servers/blogc-runserver/blogc-runserver-9999.ebuild
index 2b8a73cdf6d4..649d7522651b 100644
--- a/www-servers/blogc-runserver/blogc-runserver-9999.ebuild
+++ b/www-servers/blogc-runserver/blogc-runserver-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://github.com/blogc/blogc-runserver.git
@@ -13,29 +13,30 @@ fi
DESCRIPTION="A simple HTTP server to test blogc websites"
HOMEPAGE="https://github.com/blogc/blogc-runserver"
-MY_PV="${PV/_/-}"
-MY_PV="${MY_PV/beta/beta.}"
-
-MY_P="${PN}-${MY_PV}"
-
-SRC_URI="https://github.com/blogc/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.xz"
+SRC_URI="https://github.com/blogc/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
if [[ ${PV} = *9999* ]]; then
SRC_URI=""
KEYWORDS=""
+ DEPEND="=dev-libs/squareball-9999"
else
- S="${WORKDIR}/${MY_P}"
+ DEPEND=">=dev-libs/squareball-0.1"
fi
LICENSE="BSD"
SLOT="0"
IUSE=""
-RDEPEND="dev-libs/libevent
+RDEPEND="${DEPEND}
+ dev-libs/libevent
sys-apps/file"
-DEPEND="${RDEPEND}"
src_prepare() {
[[ ${PV} = *9999* ]] && eautoreconf
default
}
+
+src_configure() {
+ econf \
+ --with-squareball=system
+}