summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xauth')
-rw-r--r--x11-apps/xauth/xauth-1.1.ebuild10
-rw-r--r--x11-apps/xauth/xauth-9999.ebuild10
2 files changed, 4 insertions, 16 deletions
diff --git a/x11-apps/xauth/xauth-1.1.ebuild b/x11-apps/xauth/xauth-1.1.ebuild
index 838c880146d3..bde249ad877b 100644
--- a/x11-apps/xauth/xauth-1.1.ebuild
+++ b/x11-apps/xauth/xauth-1.1.ebuild
@@ -12,8 +12,8 @@ else
fi
DESCRIPTION="X authority file utility"
-IUSE="ipv6 test"
-RESTRICT="!test? ( test )"
+IUSE="ipv6"
+RESTRICT="test" # Depends on dead cmdtest package
RDEPEND="x11-libs/libX11
x11-libs/libXau
@@ -21,15 +21,9 @@ RDEPEND="x11-libs/libX11
x11-libs/libXmu"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-BDEPEND="test? ( dev-util/cmdtest )"
pkg_setup() {
XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
)
}
-
-src_test() {
- addwrite /proc/self/comm
- emake check
-}
diff --git a/x11-apps/xauth/xauth-9999.ebuild b/x11-apps/xauth/xauth-9999.ebuild
index 303aa1063e26..f46da39bc300 100644
--- a/x11-apps/xauth/xauth-9999.ebuild
+++ b/x11-apps/xauth/xauth-9999.ebuild
@@ -12,8 +12,8 @@ else
fi
DESCRIPTION="X authority file utility"
-IUSE="ipv6 test"
-RESTRICT="!test? ( test )"
+IUSE="ipv6"
+RESTRICT="test" # Depends on dead cmdtest package
RDEPEND="x11-libs/libX11
x11-libs/libXau
@@ -21,15 +21,9 @@ RDEPEND="x11-libs/libX11
x11-libs/libXmu"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-BDEPEND="test? ( dev-util/cmdtest )"
pkg_setup() {
XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
)
}
-
-src_test() {
- addwrite /proc/self/comm
- emake check
-}