summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/scripts/scripts-1.0.1-r1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11-apps/scripts/scripts-1.0.1-r1.ebuild b/x11-apps/scripts/scripts-1.0.1-r1.ebuild
index bee20312524c..064806f4a2fe 100644
--- a/x11-apps/scripts/scripts-1.0.1-r1.ebuild
+++ b/x11-apps/scripts/scripts-1.0.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
+EAPI=5
XORG_STATIC="no"
inherit xorg-2
@@ -9,6 +9,7 @@ inherit xorg-2
DESCRIPTION="start an X program on a remote machine"
KEYWORDS="amd64 arm ~arm64 ~mips ppc ppc64 s390 sh ~sparc x86 ~amd64-linux ~x86-linux"
IUSE=""
+
RDEPEND="x11-libs/libX11"
DEPEND="${RDEPEND}"
@@ -16,5 +17,5 @@ src_install() {
xorg-2_src_install
# Requires ksh, assumes hostname(1) is in /usr/bin
- rm "${ED}"/usr/bin/xauth_switch_to_sun-des-1
+ rm "${ED%/}"/usr/bin/xauth_switch_to_sun-des-1 || die
}