summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-base/xcb-proto')
-rw-r--r--x11-base/xcb-proto/Manifest3
-rw-r--r--x11-base/xcb-proto/metadata.xml13
-rw-r--r--x11-base/xcb-proto/xcb-proto-1.16.0.ebuild (renamed from x11-base/xcb-proto/xcb-proto-1.14.1.ebuild)16
-rw-r--r--x11-base/xcb-proto/xcb-proto-1.17.0.ebuild49
4 files changed, 66 insertions, 15 deletions
diff --git a/x11-base/xcb-proto/Manifest b/x11-base/xcb-proto/Manifest
index 8a02025c775e..a85212c9bc77 100644
--- a/x11-base/xcb-proto/Manifest
+++ b/x11-base/xcb-proto/Manifest
@@ -1 +1,2 @@
-DIST xcb-proto-1.14.1.tar.xz 143588 BLAKE2B 24983ec26632e93ef2d0c854cd41272925b6f3aab2642701232b73bc37d200d794c46f438e4a4102484e6ac9723e78c923b99cc78ada3541f43eaf0ad7ebc863 SHA512 140fbf48483bacc7f6b70fdcf76f9e4ff0e87df9cb3a071cea47d8fe4574407cdefcfbd674099014d297e5fc010748e71d8609fca4cc32e8b25c634f928b727d
+DIST xcb-proto-1.16.0.tar.xz 151612 BLAKE2B 1c59ae4c71e697bd4f0298f6e0ea5235fc47baa9cf584e079258f1da8be538d1b67dc45f1325d82495247d0f8020d0244ca334de3794b410a1feaceabd6b285e SHA512 54906f379a7aa2cbbfbbe54764c02dbf522ca8f6c54e07d4faae471aac3aee25d0359be38c808c8da887de228aed745582a78b2f56714b023bca8f3513b24972
+DIST xcb-proto-1.17.0.tar.xz 151748 BLAKE2B 0f46d040062fca4f6b598bdb7ab7a254b9aefce198812af82fd2112e06e88277e3c9e0a3bab161930b56688e71e1848bb859d4f33588f9496fe7399f9758b9a7 SHA512 34c3795e5a48a66d89b72ee1777fb0bede489d5ec07018e6c9ef3c13bdd60b0358fc2c04a1f0ed0acb5b681aeeb92033db579036e4f5edd967fe56714c03acdf
diff --git a/x11-base/xcb-proto/metadata.xml b/x11-base/xcb-proto/metadata.xml
index e943b72b8a48..161789742636 100644
--- a/x11-base/xcb-proto/metadata.xml
+++ b/x11-base/xcb-proto/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>x11@gentoo.org</email>
- <name>X11</name>
-</maintainer>
+ <maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="freedesktop-gitlab">xorg/proto/xcbproto</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/x11-base/xcb-proto/xcb-proto-1.14.1.ebuild b/x11-base/xcb-proto/xcb-proto-1.16.0.ebuild
index e7aaddbcc928..1c96c02f2a48 100644
--- a/x11-base/xcb-proto/xcb-proto-1.14.1.ebuild
+++ b/x11-base/xcb-proto/xcb-proto-1.16.0.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{10..12} )
XORG_TARBALL_SUFFIX="xz"
XORG_MODULE=proto/
-XORG_MULTILIB=yes
inherit python-r1 xorg-3
@@ -14,8 +13,7 @@ DESCRIPTION="X C-language Bindings protocol headers"
HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/proto/xcbproto"
EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/xcbproto.git"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND=""
@@ -29,7 +27,7 @@ BDEPEND="
ECONF_SOURCE="${S}"
-multilib_src_configure() {
+src_configure() {
# Don't use Python to find sitedir here.
PYTHON=true default
}
@@ -44,8 +42,8 @@ xcbgen_install() {
python_optimize
}
-multilib_src_install() {
+src_install() {
# Restrict SUBDIRS to prevent xcbgen with empty sitedir.
emake install DESTDIR="${D}" SUBDIRS=src
- multilib_is_native_abi && python_foreach_impl xcbgen_install
+ python_foreach_impl xcbgen_install
}
diff --git a/x11-base/xcb-proto/xcb-proto-1.17.0.ebuild b/x11-base/xcb-proto/xcb-proto-1.17.0.ebuild
new file mode 100644
index 000000000000..a7af99861180
--- /dev/null
+++ b/x11-base/xcb-proto/xcb-proto-1.17.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+XORG_TARBALL_SUFFIX="xz"
+XORG_MODULE=proto/
+
+inherit python-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/proto/xcbproto"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/xcbproto.git"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2
+"
+
+ECONF_SOURCE="${S}"
+
+src_configure() {
+ # Don't use Python to find sitedir here.
+ PYTHON=true default
+}
+
+src_compile() {
+ :
+}
+
+xcbgen_install() {
+ # Use eclass to find sitedir instead.
+ emake -C xcbgen install DESTDIR="${D}" pythondir="$(python_get_sitedir)"
+ python_optimize
+}
+
+src_install() {
+ # Restrict SUBDIRS to prevent xcbgen with empty sitedir.
+ emake install DESTDIR="${D}" SUBDIRS=src
+ python_foreach_impl xcbgen_install
+}