summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/nvidia-drivers/nvidia-drivers-440.36.ebuild')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-440.36.ebuild46
1 files changed, 7 insertions, 39 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-440.36.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-440.36.ebuild
index f1723d4e80de..388adda4e50b 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-440.36.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-440.36.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic linux-info linux-mod multilib-minimal nvidia-driver \
- portability toolchain-funcs unpacker user udev
+EAPI=7
+inherit desktop flag-o-matic linux-info linux-mod multilib-minimal \
+ nvidia-driver portability toolchain-funcs unpacker user udev
DESCRIPTION="NVIDIA Accelerated Graphics Driver"
HOMEPAGE="https://www.nvidia.com/"
@@ -84,47 +84,15 @@ S=${WORKDIR}/
PATCHES=(
"${FILESDIR}"/${PN}-440.26-locale.patch
)
-
-nvidia_drivers_versions_check() {
- if use amd64 && has_multilib_profile && \
- [ "${DEFAULT_ABI}" != "amd64" ]; then
- eerror "This ebuild doesn't currently support changing your default ABI"
- die "Unexpected \${DEFAULT_ABI} = ${DEFAULT_ABI}"
- fi
-
- if use kernel_linux && kernel_is ge 5 4; then
- ewarn "Gentoo supports kernels which are supported by NVIDIA"
- ewarn "which are limited to the following kernels:"
- ewarn "<sys-kernel/gentoo-sources-5.4"
- ewarn "<sys-kernel/vanilla-sources-5.4"
- ewarn ""
- ewarn "You are free to utilize epatch_user to provide whatever"
- ewarn "support you feel is appropriate, but will not receive"
- ewarn "support as a result of those changes."
- ewarn ""
- ewarn "Do not file a bug report about this."
- ewarn ""
- fi
-
- # Since Nvidia ships many different series of drivers, we need to give the user
- # some kind of guidance as to what version they should install. This tries
- # to point the user in the right direction but can't be perfect. check
- # nvidia-driver.eclass
- nvidia-driver-check-warning
-
- # Kernel features/options to check for
- CONFIG_CHECK="!DEBUG_MUTEXES !I2C_NVIDIA_GPU ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
-
- # Now do the above checks
- use kernel_linux && check_extra_config
-}
+NV_KV_MAX_PLUS="5.4"
+CONFIG_CHECK="!DEBUG_MUTEXES !I2C_NVIDIA_GPU ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
pkg_pretend() {
- nvidia_drivers_versions_check
+ nvidia-driver_check
}
pkg_setup() {
- nvidia_drivers_versions_check
+ nvidia-driver_check
# try to turn off distcc and ccache for people that have a problem with it
export DISTCC_DISABLE=1