summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-input-libinput/xf86-input-libinput-0.30.0.ebuild')
-rw-r--r--x11-drivers/xf86-input-libinput/xf86-input-libinput-0.30.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-libinput/xf86-input-libinput-0.30.0.ebuild b/x11-drivers/xf86-input-libinput/xf86-input-libinput-0.30.0.ebuild
new file mode 100644
index 000000000000..7fdfa6fd1434
--- /dev/null
+++ b/x11-drivers/xf86-input-libinput/xf86-input-libinput-0.30.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info xorg-3
+
+DESCRIPTION="X.org input driver based on libinput"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libinput-1.7.0:0="
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=( "README.md" )
+
+pkg_pretend() {
+ CONFIG_CHECK="~TIMERFD"
+ check_extra_config
+}