summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.8.2.ebuild')
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.8.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.8.2.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.8.2.ebuild
new file mode 100644
index 000000000000..215fd1050aa1
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="kernel_linux"
+
+RDEPEND="kernel_linux? ( >=dev-libs/libevdev-0.4 )
+ >=x11-base/xorg-server-1.14
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libXtst-1.1.0"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.37
+ >=x11-proto/inputproto-2.1.99.3
+ >=x11-proto/recordproto-1.14"
+
+DOCS=( "README" )
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ echo
+ fi
+}