summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libxcvt/libxcvt-0.1.2.ebuild')
-rw-r--r--x11-libs/libxcvt/libxcvt-0.1.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/x11-libs/libxcvt/libxcvt-0.1.2.ebuild b/x11-libs/libxcvt/libxcvt-0.1.2.ebuild
new file mode 100644
index 000000000000..920def423f8f
--- /dev/null
+++ b/x11-libs/libxcvt/libxcvt-0.1.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+XORG_TARBALL_SUFFIX="xz"
+
+inherit xorg-3 meson
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="X.Org xcvt library and cvt program"
+
+RDEPEND="!<x11-base/xorg-server-1.20.11-r3"
+
+# Override xorg-3's src_prepare
+src_prepare() {
+ default
+}