summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/snorenotify')
-rw-r--r--x11-libs/snorenotify/files/snorenotify-0.7.0-include.patch20
-rw-r--r--x11-libs/snorenotify/snorenotify-0.7.0-r1.ebuild7
2 files changed, 25 insertions, 2 deletions
diff --git a/x11-libs/snorenotify/files/snorenotify-0.7.0-include.patch b/x11-libs/snorenotify/files/snorenotify-0.7.0-include.patch
new file mode 100644
index 000000000000..ee99e26ed47c
--- /dev/null
+++ b/x11-libs/snorenotify/files/snorenotify-0.7.0-include.patch
@@ -0,0 +1,20 @@
+Bug: https://bugs.gentoo.org/587898
+
+commit 96fd4a7914e8daf924829606dc25f9e4767401dd
+Author: Hannah von Reth <vonreth@kde.org>
+Date: Mon Nov 21 08:57:00 2016 +0100
+
+ [WIP] Support to build with static Qt and static plugins
+
+diff --git a/src/libsnore/notification/icon.cpp b/src/libsnore/notification/icon.cpp
+index b95ceb4..5c7c139 100644
+--- a/src/libsnore/notification/icon.cpp
++++ b/src/libsnore/notification/icon.cpp
+@@ -25,6 +25,7 @@
+ #include <QNetworkReply>
+ #include <QNetworkRequest>
+ #include <QUrl>
++#include <QTime>
+
+ using namespace Snore;
+
diff --git a/x11-libs/snorenotify/snorenotify-0.7.0-r1.ebuild b/x11-libs/snorenotify/snorenotify-0.7.0-r1.ebuild
index ad78029107e1..2fece7ed49e4 100644
--- a/x11-libs/snorenotify/snorenotify-0.7.0-r1.ebuild
+++ b/x11-libs/snorenotify/snorenotify-0.7.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,7 +30,10 @@ DEPEND="${RDEPEND}
test? ( dev-qt/qttest:5 )
"
-PATCHES=( "${FILESDIR}/${P}-desktop.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-desktop.patch"
+ "${FILESDIR}/${P}-include.patch"
+)
src_configure() {
local mycmakeargs=(