summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/xcb-util-image/xcb-util-image-0.3.9-r1.ebuild')
-rw-r--r--x11-libs/xcb-util-image/xcb-util-image-0.3.9-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-image/xcb-util-image-0.3.9-r1.ebuild b/x11-libs/xcb-util-image/xcb-util-image-0.3.9-r1.ebuild
new file mode 100644
index 000000000000..bad5828a2bfe
--- /dev/null
+++ b/x11-libs/xcb-util-image/xcb-util-image-0.3.9-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MODULE=/
+XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-image"
+EGIT_HAS_SUBMODULES=yes
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND=">=x11-libs/xcb-util-${PV}[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.1
+ test? ( >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-return-type.patch
+)
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc doxygen)
+ )
+
+ xorg-2_src_configure
+}