summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libfm/Manifest1
-rw-r--r--x11-libs/libfm/libfm-1.2.5.ebuild127
-rw-r--r--x11-libs/libfm/libfm-9999.ebuild123
3 files changed, 0 insertions, 251 deletions
diff --git a/x11-libs/libfm/Manifest b/x11-libs/libfm/Manifest
index ff3641052b80..0aa1137e43bd 100644
--- a/x11-libs/libfm/Manifest
+++ b/x11-libs/libfm/Manifest
@@ -1,2 +1 @@
-DIST libfm-1.2.5.tar.gz 1261152 BLAKE2B 30da6771ad4ab31be675a3af2ce7c9dd04e80be9f33b25300bf386f45f9fd652654e211c312d1e283a63cdbde4f5c8e3673a36fc0075e3b1981d9f5995683057 SHA512 0bc7910081cadc4c8c4648f3483fb5791e9480700400ded452dd5985e7fb0d8524f2c676f0171a5cd283422a13f240f40cfe5ccc8d10dce02dd784d62250b7cc
DIST libfm-1.3.1.tar.gz 1290374 BLAKE2B 3df27fc6b4afd089e51cd36db0f764e9359b0c6373e0ff484aa7cd2ee99170530fb60f5757ade9263a5bdd1d6be9917debb66a19cc8e13c505431050b6f3a901 SHA512 82bbcb1b9c7d4543bcb075906bdc1554462b041ad936e2f0334ae478302b19808cdbfe6d0c86a039bbd72a2491f2d2ada61a324fe3933a8dde16a03d93bef2bc
diff --git a/x11-libs/libfm/libfm-1.2.5.ebuild b/x11-libs/libfm/libfm-1.2.5.ebuild
deleted file mode 100644
index a94b843ec8e5..000000000000
--- a/x11-libs/libfm/libfm-1.2.5.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools multilib vala xdg-utils
-
-MY_PV=${PV/_/}
-MY_P="${PN}-${MY_PV}"
-DESCRIPTION="A library for file management"
-HOMEPAGE="https://wiki.lxde.org/en/PCManFM"
-SRC_URI="https://github.com/lxde/libfm/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
-
-KEYWORDS="~alpha amd64 arm ~arm64 ~mips ppc x86 ~amd64-linux ~x86-linux"
-LICENSE="GPL-2"
-SLOT="0/4.5.0" #copy ABI_VERSION because it seems upstream change it randomly
-IUSE="+automount debug doc examples exif gtk udisks vala"
-
-COMMON_DEPEND=">=dev-libs/glib-2.18:2
- gtk? ( >=x11-libs/gtk+-2.16:2 )
- >=lxde-base/menu-cache-0.3.2:=
- ~x11-libs/libfm-extra-${PV}
- udisks? ( dev-libs/dbus-glib )"
-RDEPEND="${COMMON_DEPEND}
- !lxde-base/lxshortcut
- x11-misc/shared-mime-info
- automount? (
- udisks? ( gnome-base/gvfs[udev,udisks] )
- !udisks? ( gnome-base/gvfs[udev] )
- )
- exif? ( media-libs/libexif )"
-DEPEND="${COMMON_DEPEND}
- vala? ( $(vala_depend) )
- doc? (
- dev-util/gtk-doc
- )
- app-arch/xz-utils
- >=dev-util/intltool-0.40
- virtual/pkgconfig
- sys-devel/gettext"
-
-S="${WORKDIR}"/${MY_P}
-
-REQUIRED_USE="udisks? ( automount ) doc? ( gtk )"
-
-src_prepare() {
- # Fix use after free bug, see
- # https://github.com/lxde/libfm/pull/11/commits/9e3a809c6a8a5079f05e04edac9457d317822321
- epatch "${FILESDIR}"/libfm-fix-use-after-free.diff
-
- if ! use doc; then
- sed -ie '/^SUBDIR.*=/s#docs##' "${S}"/Makefile.am || die "sed failed"
- sed -ie '/^[[:space:]]*docs/d' configure.ac || die "sed failed"
- fi
- sed -i -e "s:-O0::" -e "/-DG_ENABLE_DEBUG/s: -g::" \
- configure.ac || die "sed failed"
-
- #disable unused translations. Bug #356029
- for trans in app-chooser ask-rename exec-file file-prop preferred-apps \
- progress;do
- echo "data/ui/"${trans}.ui >> po/POTFILES.in
- done
- #Remove -Werror for automake-1.12. Bug #421101
- sed -i "s:-Werror::" configure.ac || die
-
- # subslot sanity check
- local sub_slot=${SLOT#*/}
- local libfm_major_abi=$(sed -rne '/ABI_VERSION/s:.*=::p' src/Makefile.am | tr ':' '.')
-
- if [[ ${sub_slot} != ${libfm_major_abi} ]]; then
- eerror "Ebuild sub-slot (${sub_slot}) does not match ABI_VERSION(${libfm_major_abi})"
- eerror "Please update SLOT variable as follows:"
- eerror " SLOT=\"${SLOT%%/*}/${libfm_major_abi}\""
- eerror
- die "sub-slot sanity check failed"
- fi
-
- eautoreconf
- rm -r autom4te.cache || die
- use vala && export VALAC="$(type -p valac-$(vala_best_api_version))"
-}
-
-src_configure() {
- econf \
- --disable-static \
- $(use_enable examples demo) \
- $(use_enable exif) \
- $(use_enable debug) \
- $(use_enable udisks) \
- $(use_enable vala actions) \
- $(use_with gtk) \
- $(use_enable doc gtk-doc) \
- --with-html-dir=/usr/share/doc/${PF}/html
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -exec rm -f '{}' +
- # Sometimes a directory is created instead of a symlink. No idea why...
- # It is wrong anyway. We expect a libfm-1.0 directory and then a libfm
- # symlink to it.
- if [[ -h ${D}/usr/include/${PN} || -d ${D}/usr/include/${PN} ]]; then
- rm -r "${D}"/usr/include/${PN}
- fi
- # Remove files installed by split-off libfm-extra package
- rm "${D}"/usr/include/libfm-1.0/fm-{extra,version,xml-file}.h
- rm "${D}"/usr/$(get_libdir)/libfm-extra*
- rm "${D}"/usr/$(get_libdir)/pkgconfig/libfm-extra.pc
-}
-
-pkg_preinst() {
- # Resolve the symlink mess. Bug #439570
- [[ -d "${ROOT}"/usr/include/${PN} ]] && \
- rm -rf "${ROOT}"/usr/include/${PN}
- if [[ -d "${D}"/usr/include/${PN}-1.0 ]]; then
- cd "${D}"/usr/include
- ln -s --force ${PN}-1.0 ${PN}
- fi
-}
-
-pkg_postinst() {
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- xdg_mimeinfo_database_update
-}
diff --git a/x11-libs/libfm/libfm-9999.ebuild b/x11-libs/libfm/libfm-9999.ebuild
deleted file mode 100644
index 559e07188526..000000000000
--- a/x11-libs/libfm/libfm-9999.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-EGIT_REPO_URI="https://github.com/lxde/${PN}"
-inherit autotools git-r3 vala xdg-utils
-
-DESCRIPTION="A library for file management"
-HOMEPAGE="https://wiki.lxde.org/en/PCManFM"
-
-LICENSE="GPL-2"
-SLOT="0/4.4.0" #copy ABI_VERSION because it seems upstream change it randomly
-IUSE="+automount debug doc examples exif gtk udisks vala"
-KEYWORDS=""
-
-COMMON_DEPEND=">=dev-libs/glib-2.18:2
- gtk? ( >=x11-libs/gtk+-2.16:2 )
- >=lxde-base/menu-cache-0.3.2:=
- x11-libs/libfm-extra"
-RDEPEND="${COMMON_DEPEND}
- !lxde-base/lxshortcut
- x11-misc/shared-mime-info
- automount? (
- udisks? ( gnome-base/gvfs[udev,udisks] )
- !udisks? ( gnome-base/gvfs[udev] )
- )
- exif? ( media-libs/libexif )"
-DEPEND="${COMMON_DEPEND}
- vala? ( $(vala_depend) )
- doc? (
- dev-util/gtk-doc
- )
- >=dev-util/intltool-0.40
- virtual/pkgconfig
- sys-devel/gettext
- dev-util/glib-utils"
-
-DOCS=( AUTHORS TODO )
-
-REQUIRED_USE="udisks? ( automount ) doc? ( gtk )"
-
-src_prepare() {
- if ! use doc; then
- sed -ie '/^SUBDIR.*=/s#docs##' "${S}"/Makefile.am || die "sed failed"
- sed -ie '/^[[:space:]]*docs/d' configure.ac || die "sed failed"
- else
- gtkdocize --copy || die
- fi
- sed -i -e "s:-O0::" -e "/-DG_ENABLE_DEBUG/s: -g::" \
- configure.ac || die "sed failed"
-
- intltoolize --force --copy --automake || die
- #disable unused translations. Bug #356029
- for trans in app-chooser ask-rename exec-file file-prop preferred-apps \
- progress;do
- echo "data/ui/"${trans}.ui >> po/POTFILES.in
- done
- #Remove -Werror for automake-1.12. Bug #421101
- sed -i "s:-Werror::" configure.ac || die
-
- # subslot sanity check
- local sub_slot=${SLOT#*/}
- local libfm_major_abi=$(sed -rne '/ABI_VERSION/s:.*=::p' src/Makefile.am | tr ':' '.')
-
- if [[ ${sub_slot} != ${libfm_major_abi} ]]; then
- eerror "Ebuild sub-slot (${sub_slot}) does not match ABI_VERSION(${libfm_major_abi})"
- eerror "Please update SLOT variable as follows:"
- eerror " SLOT=\"${SLOT%%/*}/${libfm_major_abi}\""
- eerror
- die "sub-slot sanity check failed"
- fi
-
- eautoreconf
- rm -r autom4te.cache || die
- use vala && export VALAC="$(type -p valac-$(vala_best_api_version))"
-}
-
-src_configure() {
- econf \
- --disable-static \
- $(use_enable examples demo) \
- $(use_enable exif) \
- $(use_enable debug) \
- $(use_enable udisks) \
- $(use_enable vala actions) \
- $(use_with gtk) \
- $(use_enable doc gtk-doc) \
- --with-html-dir=/usr/share/doc/${PF}/html
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -exec rm -f '{}' +
- # Sometimes a directory is created instead of a symlink. No idea why...
- # It is wrong anyway. We expect a libfm-1.0 directory and then a libfm
- # symlink to it.
- if [[ -h ${D}/usr/include/${PN} || -d ${D}/usr/include/${PN} ]]; then
- rm -r "${D}"/usr/include/${PN}
- fi
- # Remove files installed by split-off libfm-extra package
- rm "${D}"/usr/include/libfm-1.0/fm-{extra,version,xml-file}.h
- rm "${D}"/usr/$(get_libdir)/libfm-extra*
- rm "${D}"/usr/$(get_libdir)/pkgconfig/libfm-extra.pc
-}
-
-pkg_preinst() {
- # Resolve the symlink mess. Bug #439570
- [[ -d "${ROOT}"/usr/include/${PN} ]] && \
- rm -rf "${ROOT}"/usr/include/${PN}
- if [[ -d "${D}"/usr/include/${PN}-1.0 ]]; then
- cd "${D}"/usr/include
- ln -s --force ${PN}-1.0 ${PN}
- fi
-}
-
-pkg_postinst() {
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- xdg_mimeinfo_database_update
-}