summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/albert/albert-0.8.0.ebuild')
-rw-r--r--x11-misc/albert/albert-0.8.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/albert/albert-0.8.0.ebuild b/x11-misc/albert/albert-0.8.0.ebuild
new file mode 100644
index 000000000000..d02847033903
--- /dev/null
+++ b/x11-misc/albert/albert-0.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Desktop agnostic launcher"
+HOMEPAGE="https://github.com/manuelschneid3r/albert"
+SRC_URI="https://github.com/manuelschneid3r/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-cpp/muParser
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}
+ dev-qt/qtsvg:5
+"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}