summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/bbdate/bbdate-0.2.4-r1.ebuild')
-rw-r--r--x11-misc/bbdate/bbdate-0.2.4-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/bbdate/bbdate-0.2.4-r1.ebuild b/x11-misc/bbdate/bbdate-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..67068033465c
--- /dev/null
+++ b/x11-misc/bbdate/bbdate-0.2.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+DESCRIPTION="blackbox date display"
+HOMEPAGE="http://sourceforge.net/projects/bbtools"
+SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86 ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ sed -i \
+ -e 's|-helvetica-|-*-|g' \
+ resource.cc data/${PN}.{nobb,style} || die
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README AUTHORS BUGS INSTALL ChangeLog TODO
+
+ # since multiple bbtools packages provide this file, install
+ # it in /usr/share/doc/${PF}
+ mv "${D}"/usr/share/bbtools/bbtoolsrc.in \
+ "${D}"/usr/share/doc/${PF}/bbtoolsrc.example
+}