summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/bbmail/bbmail-0.9.3.ebuild')
-rw-r--r--x11-misc/bbmail/bbmail-0.9.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/bbmail/bbmail-0.9.3.ebuild b/x11-misc/bbmail/bbmail-0.9.3.ebuild
new file mode 100644
index 000000000000..ab3d3ce8e92d
--- /dev/null
+++ b/x11-misc/bbmail/bbmail-0.9.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="blackbox mail notification"
+HOMEPAGE="http://sourceforge.net/projects/bbtools"
+SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-wm/blackbox
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch \
+ "${FILESDIR}"/${P}-gcc4.4.patch
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dobin scripts/bbmailparsefm.pl
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README TODO
+}