summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/gbase')
-rw-r--r--x11-misc/gbase/files/gbase-0.5-gtk.patch9
-rw-r--r--x11-misc/gbase/gbase-0.5-r1.ebuild9
2 files changed, 9 insertions, 9 deletions
diff --git a/x11-misc/gbase/files/gbase-0.5-gtk.patch b/x11-misc/gbase/files/gbase-0.5-gtk.patch
index 38936e79738c..4763839624af 100644
--- a/x11-misc/gbase/files/gbase-0.5-gtk.patch
+++ b/x11-misc/gbase/files/gbase-0.5-gtk.patch
@@ -1,13 +1,12 @@
-diff -ur gbase-0.5.orig/Makefile gbase-0.5/Makefile
---- gbase-0.5.orig/Makefile 1999-10-28 00:23:51.000000000 +0300
-+++ gbase-0.5/Makefile 2008-01-16 14:24:55.000000000 +0200
+--- a/Makefile
++++ b/Makefile
@@ -1,15 +1,15 @@
-CC = gcc
-CCFLAGS = `gtk-config --cflags`
-LDFLAGS = `gtk-config --libs`
+CC ?= gcc
-+CFLAGS += `pkg-config --cflags gtk+-2.0`
-+LIBS = `pkg-config --libs gtk+-2.0`
++CFLAGS += `${PKG_CONFIG} --cflags gtk+-2.0`
++LIBS = `${PKG_CONFIG} --libs gtk+-2.0`
gbase: gbase.o
- $(CC) gbase.o $(LDFLAGS) -o gbase
diff --git a/x11-misc/gbase/gbase-0.5-r1.ebuild b/x11-misc/gbase/gbase-0.5-r1.ebuild
index 2a57e0d299c5..e40430eebba8 100644
--- a/x11-misc/gbase/gbase-0.5-r1.ebuild
+++ b/x11-misc/gbase/gbase-0.5-r1.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit toolchain-funcs
-DESCRIPTION="a convert program for decimal, hexadecimal, octal and binary values"
+DESCRIPTION="A convert program for decimal, hexadecimal, octal and binary values"
HOMEPAGE="http://www.fluxcode.net"
SRC_URI="http://www.fluxcode.net/files/${P}.tar.gz"
LICENSE="Artistic"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
+
RESTRICT="test" #424671
RDEPEND="x11-libs/gtk+:2"
@@ -21,7 +22,7 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}"/${P}-gtk.patch )
src_compile() {
- tc-export CC
+ tc-export CC PKG_CONFIG
default
}