summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/grabc')
-rw-r--r--x11-misc/grabc/grabc-1.1-r1.ebuild8
-rw-r--r--x11-misc/grabc/grabc-1.1-r2.ebuild32
2 files changed, 36 insertions, 4 deletions
diff --git a/x11-misc/grabc/grabc-1.1-r1.ebuild b/x11-misc/grabc/grabc-1.1-r1.ebuild
index 05b5805d092c..5d685bde8d15 100644
--- a/x11-misc/grabc/grabc-1.1-r1.ebuild
+++ b/x11-misc/grabc/grabc-1.1-r1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit eutils toolchain-funcs
S="${WORKDIR}/${PN}${PV}"
-DESCRIPTION="determine the color string in hex (or RGB components) by clicking on a pixel on the screen"
-HOMEPAGE="http://www.muquit.com/muquit/software/grabc/grabc.html"
-SRC_URI="http://www.muquit.com/muquit/software/${PN}/${PN}${PV}.tar.gz"
+DESCRIPTION="Identify color of a pixel on the screen by clicking on a pixel on the screen"
+HOMEPAGE="https://www.muquit.com/muquit/software/grabc/grabc.html"
+SRC_URI="https://www.muquit.com/muquit/software/${PN}/${PN}${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
diff --git a/x11-misc/grabc/grabc-1.1-r2.ebuild b/x11-misc/grabc/grabc-1.1-r2.ebuild
new file mode 100644
index 000000000000..b51d8973e67d
--- /dev/null
+++ b/x11-misc/grabc/grabc-1.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Identify color of a pixel on the screen by clicking on a pixel on the screen"
+HOMEPAGE="https://www.muquit.com/muquit/software/grabc/grabc.html"
+SRC_URI="https://www.muquit.com/muquit/software/${PN}/${PN}${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${PN}${PV}"
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin grabc
+ einstalldocs
+}