summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/grun/grun-0.9.3-r1.ebuild')
-rw-r--r--x11-misc/grun/grun-0.9.3-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/grun/grun-0.9.3-r1.ebuild b/x11-misc/grun/grun-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..ebc39634a8f6
--- /dev/null
+++ b/x11-misc/grun/grun-0.9.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="gRun is a GTK based Run dialog that closely resembles the Windows Run dialog, just like xexec"
+HOMEPAGE="http://code.google.com/p/grun/"
+SRC_URI="http://grun.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no_nls.patch
+}
+
+src_configure() {
+ [[ -z ${TERM} ]] && TERM=xterm
+
+ econf \
+ $(use_enable nls) \
+ --disable-gtktest \
+ --enable-associations \
+ --enable-testfile \
+ --with-default-xterm=${TERM}
+}
+
+src_install() {
+ default
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+}