summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/i3blocks')
-rw-r--r--x11-misc/i3blocks/Manifest1
-rw-r--r--x11-misc/i3blocks/files/i3blocks-disable-bash-completion.patch17
-rw-r--r--x11-misc/i3blocks/i3blocks-1.5.ebuild34
3 files changed, 52 insertions, 0 deletions
diff --git a/x11-misc/i3blocks/Manifest b/x11-misc/i3blocks/Manifest
index b6227d86001c..21bd03633fd3 100644
--- a/x11-misc/i3blocks/Manifest
+++ b/x11-misc/i3blocks/Manifest
@@ -1 +1,2 @@
DIST i3blocks-1.4.tar.gz 35943 BLAKE2B 84c1d08d173238ecd875254015dc78cb560cefb1eb11d9628dc8572fb44f9724927e622aecc9888c43fdc435df8b07f6b07e22c4543354edb2d92cc8d5d00321 SHA512 f04fd68d59097b21bc88f3097dff137de656dd3fa696d9c04b987ba25136e5e5d9cacb63998e8635fe55fcf94f47900aec8c79d98e1d1d8847856a89ad9a6578
+DIST i3blocks-1.5.tar.gz 66019 BLAKE2B 0378dac61d2f0049dffefe2a3f98512518aef311f2d9d79b72fd9882834c6a09c8954e7ca906fb96bbcc76992288fe659b4977f2cfad1234dca27ec9131ac720 SHA512 759829d59f94070251378d437891c2df05715fbd0b734c34dd41767d61957f301c6125b0058668295b8eeac29038fae6b2e8c194f903398ee736662213d1d534
diff --git a/x11-misc/i3blocks/files/i3blocks-disable-bash-completion.patch b/x11-misc/i3blocks/files/i3blocks-disable-bash-completion.patch
new file mode 100644
index 000000000000..bfca548e06f1
--- /dev/null
+++ b/x11-misc/i3blocks/files/i3blocks-disable-bash-completion.patch
@@ -0,0 +1,17 @@
+--- a/Makefile.am 2019-10-20 22:46:55.603462157 +0200
++++ b/Makefile.am 2019-10-20 22:47:29.893461028 +0200
+@@ -29,14 +29,3 @@
+
+ dist_sysconf_DATA = \
+ i3blocks.conf
+-
+-if ENABLE_BASH_COMPLETION
+-bashcompletiondir = $(BASH_COMPLETION_DIR)
+-bashcompletion_DATA = bash-completion
+-
+-install-data-local:
+- ( cd '$(DESTDIR)$(BASH_COMPLETION_DIR)' && mv bash-completion i3blocks )
+-
+-uninstall-local:
+- ( cd '$(DESTDIR)$(BASH_COMPLETION_DIR)' && rm -rf i3blocks )
+-endif
diff --git a/x11-misc/i3blocks/i3blocks-1.5.ebuild b/x11-misc/i3blocks/i3blocks-1.5.ebuild
new file mode 100644
index 000000000000..d8ceeacffbb7
--- /dev/null
+++ b/x11-misc/i3blocks/i3blocks-1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+fi
+
+DESCRIPTION="highly flexible status line for the i3 window manager"
+HOMEPAGE="https://github.com/vivien/i3blocks"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/vivien/${PN}"
+else
+ SRC_URI="https://github.com/vivien/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+SLOT="0"
+LICENSE="GPL-3"
+
+PATCHES=( "${FILESDIR}"/${PN}-disable-bash-completion.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ newbashcomp bash-completion ${PN}
+}