summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/imake/imake-1.0.6.ebuild')
-rw-r--r--x11-misc/imake/imake-1.0.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-misc/imake/imake-1.0.6.ebuild b/x11-misc/imake/imake-1.0.6.ebuild
new file mode 100644
index 000000000000..11067bf14c59
--- /dev/null
+++ b/x11-misc/imake/imake-1.0.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+XORG_STATIC=no
+inherit xorg-2
+
+DESCRIPTION="C preprocessor interface to the make utility"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-misc/xorg-cf-files"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ # don't use Sun compilers on Solaris, we want GCC from prefix
+ sed -i \
+ -e "1s/^/#if defined(sun)\n# undef sun\n#endif/" \
+ imake.c imakemdep.h || die "sed failed"
+ xorg-2_src_prepare
+}