summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/rofi-calc')
-rw-r--r--x11-misc/rofi-calc/Manifest1
-rw-r--r--x11-misc/rofi-calc/metadata.xml12
-rw-r--r--x11-misc/rofi-calc/rofi-calc-1.5.ebuild26
-rw-r--r--x11-misc/rofi-calc/rofi-calc-9999.ebuild27
4 files changed, 66 insertions, 0 deletions
diff --git a/x11-misc/rofi-calc/Manifest b/x11-misc/rofi-calc/Manifest
new file mode 100644
index 000000000000..10d3a9cc37b2
--- /dev/null
+++ b/x11-misc/rofi-calc/Manifest
@@ -0,0 +1 @@
+DIST rofi-calc-1.5.tar.gz 1693385 BLAKE2B 7ff21873ee298c4295f2766917318796d6327959e63d99adc86857d2e05534e77062c9546ba8c6cf645a12ae46147e4583a61fc95dbc6953ee642449ff108d40 SHA512 04213b6489cd9e3c5085a88cee07ee9413819c19d4ee08f6e2eef3ad418d21b5acaf1d4ef21f1495d81694e5706f93598c91ada65f1bcc83ce94a6cf5d50ea0c
diff --git a/x11-misc/rofi-calc/metadata.xml b/x11-misc/rofi-calc/metadata.xml
new file mode 100644
index 000000000000..08400951b2bf
--- /dev/null
+++ b/x11-misc/rofi-calc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robin@hallabro.nu</email>
+ <name>Robin Hallabro-Kokko</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-misc/rofi-calc/rofi-calc-1.5.ebuild b/x11-misc/rofi-calc/rofi-calc-1.5.ebuild
new file mode 100644
index 000000000000..a267871cd50b
--- /dev/null
+++ b/x11-misc/rofi-calc/rofi-calc-1.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Do live calculations in rofi!"
+HOMEPAGE="https://github.com/svenstaro/rofi-calc"
+SRC_URI="https://github.com/svenstaro/rofi-calc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ x11-misc/rofi
+ >=sci-libs/libqalculate-2.0
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf -i
+}
diff --git a/x11-misc/rofi-calc/rofi-calc-9999.ebuild b/x11-misc/rofi-calc/rofi-calc-9999.ebuild
new file mode 100644
index 000000000000..c70193f7e119
--- /dev/null
+++ b/x11-misc/rofi-calc/rofi-calc-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 autotools
+
+DESCRIPTION="Do live calculations in rofi!"
+HOMEPAGE="https://github.com/svenstaro/rofi-calc"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/svenstaro/rofi-calc.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ x11-misc/rofi
+ >=sci-libs/libqalculate-2.0
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf -i
+}