summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/rofi/rofi-1.7.5.ebuild')
-rw-r--r--x11-misc/rofi/rofi-1.7.5.ebuild31
1 files changed, 18 insertions, 13 deletions
diff --git a/x11-misc/rofi/rofi-1.7.5.ebuild b/x11-misc/rofi/rofi-1.7.5.ebuild
index c51049b5e10e..69974bf5e0e4 100644
--- a/x11-misc/rofi/rofi-1.7.5.ebuild
+++ b/x11-misc/rofi/rofi-1.7.5.ebuild
@@ -1,17 +1,23 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools toolchain-funcs xdg-utils
+inherit autotools flag-o-matic toolchain-funcs xdg-utils
DESCRIPTION="A window switcher, run dialog and dmenu replacement"
HOMEPAGE="https://github.com/davatorium/rofi"
-SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.xz"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/davatorium/rofi"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 arm64 ~riscv x86"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 arm64 x86"
IUSE="+drun test +windowmode"
RESTRICT="!test? ( test )"
@@ -45,9 +51,17 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/881281
+ # fixed upstream in git next, remove on next version bump
+ filter-lto
+
# Doesn't work with reflex, bug #887049
export LEX=flex
+ # Requires bison, see https://bugs.gentoo.org/894634.
+ unset YACC
+
tc-export CC
local myeconfargs=(
@@ -59,15 +73,6 @@ src_configure() {
}
pkg_postinst() {
- for v in ${REPLACING_VERSIONS}; do
- if ver_test "${v}" -lt 1.7.0; then
- elog "Rofi 1.7.0 removed the (deprecated) xresources based configuration setup."
- elog "If you are still using old configuration setup, please convert it to new format manually."
- elog "The new format configuration can be generated by 'rofi -dump-config > ~/.config/rofi/config.rasi'."
- elog "For more information, please see https://github.com/davatorium/rofi/releases/tag/1.7.0"
- fi
- done
-
xdg_icon_cache_update
}