summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/screenkey/screenkey-1.5-r2.ebuild')
-rw-r--r--x11-misc/screenkey/screenkey-1.5-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/screenkey/screenkey-1.5-r2.ebuild b/x11-misc/screenkey/screenkey-1.5-r2.ebuild
new file mode 100644
index 000000000000..b06bc7524e75
--- /dev/null
+++ b/x11-misc/screenkey/screenkey-1.5-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="A screencast tool to display your keys inspired by Screenflick"
+HOMEPAGE="https://www.thregr.org/~wavexx/software/screenkey/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/screenkey/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/screenkey/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+RESTRICT="test"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="appindicator"
+
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ media-fonts/fontawesome
+ x11-libs/gtk+:3[X,introspection]
+ x11-misc/slop
+ appindicator? ( dev-libs/libappindicator:3[introspection] )
+"
+
+src_prepare() {
+ # Change the doc install path
+ sed -i "s|share/doc/screenkey|share/doc/${PF}|g" setup.py || die
+
+ default
+}