summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/slop/files/slop-4.3.21-no-cppcheck.patch')
-rw-r--r--x11-misc/slop/files/slop-4.3.21-no-cppcheck.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/x11-misc/slop/files/slop-4.3.21-no-cppcheck.patch b/x11-misc/slop/files/slop-4.3.21-no-cppcheck.patch
new file mode 100644
index 000000000000..f92c57f977df
--- /dev/null
+++ b/x11-misc/slop/files/slop-4.3.21-no-cppcheck.patch
@@ -0,0 +1,20 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 361f930..0982647 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -33,15 +33,6 @@ else()
+ message( FATAL_ERROR "Your operating system isn't supported yet! CMake will now exit." )
+ endif()
+
+-# Add a check target for our makefile.
+-find_program( CPPCHECK_EXECUTABLE cppcheck
+- DOC "A tool for static C/C++ code analysis." )
+-if (CPPCHECK_EXECUTABLE)
+- add_custom_target( "check"
+- COMMAND "${CPPCHECK_EXECUTABLE}" "--enable=all" "*"
+- WORKING_DIRECTORY src VERBATIM )
+-endif()
+-
+ # Here we generate some of our code if we can. I package it pre-generated
+ # so nobody has to go find and install gengetopt if they don't want to.
+ find_program( GENGETOPT_EXECUTABLE gengetopt