summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/slop/slop-7.4.ebuild')
-rw-r--r--x11-misc/slop/slop-7.4.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/x11-misc/slop/slop-7.4.ebuild b/x11-misc/slop/slop-7.4.ebuild
deleted file mode 100644
index a61629c541d3..000000000000
--- a/x11-misc/slop/slop-7.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-inherit cmake-utils
-
-DESCRIPTION="An application that queries the user for a selection for printing"
-HOMEPAGE="https://github.com/naelstrof/slop"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/naelstrof/slop.git"
-else
- SRC_URI="https://github.com/naelstrof/slop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0/${PV}"
-IUSE="opengl"
-
-RDEPEND="
- dev-libs/icu:=
- x11-libs/libX11
- x11-libs/libXext
- opengl? (
- media-libs/glew:0=
- virtual/opengl
- x11-libs/libXrender:=
- )"
-DEPEND="
- ${RDEPEND}
- media-libs/glm"
-
-src_configure() {
- local mycmakeargs=(
- -DSLOP_OPENGL=$(usex opengl)
- )
- cmake-utils_src_configure
-}