summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/synergy/files/synergy-1.4.17_p2055-test.patch')
-rw-r--r--x11-misc/synergy/files/synergy-1.4.17_p2055-test.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/synergy/files/synergy-1.4.17_p2055-test.patch b/x11-misc/synergy/files/synergy-1.4.17_p2055-test.patch
new file mode 100644
index 000000000000..e0e25c2e128b
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.4.17_p2055-test.patch
@@ -0,0 +1,33 @@
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -19,6 +19,6 @@
+ add_subdirectory(plugin)
+ add_subdirectory(micro)
+
+-if (NOT ${CMAKE_SYSTEM_NAME} MATCHES "IRIX")
++if (${WITH_GENTOO_TEST} MATCHES "ON")
+ add_subdirectory(test)
+ endif()
+--- a/src/test/CMakeLists.txt
++++ b/src/test/CMakeLists.txt
+@@ -14,20 +14,5 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+-include_directories(
+- ../../ext/gtest-1.6.0
+- ../../ext/gtest-1.6.0/include
+- ../../ext/gmock-1.6.0
+- ../../ext/gmock-1.6.0/include)
+-
+-add_library(gtest STATIC ../../ext/gtest-1.6.0/src/gtest-all.cc)
+-add_library(gmock STATIC ../../ext/gmock-1.6.0/src/gmock-all.cc)
+-
+-if (UNIX)
+- # ignore warnings in gtest and gmock
+- set_target_properties(gtest PROPERTIES COMPILE_FLAGS "-w")
+- set_target_properties(gmock PROPERTIES COMPILE_FLAGS "-w")
+-endif()
+-
+ add_subdirectory(integtests)
+ add_subdirectory(unittests)