summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/trayer-srg/trayer-srg-1.1.8-r1.ebuild')
-rw-r--r--x11-misc/trayer-srg/trayer-srg-1.1.8-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/trayer-srg/trayer-srg-1.1.8-r1.ebuild b/x11-misc/trayer-srg/trayer-srg-1.1.8-r1.ebuild
new file mode 100644
index 000000000000..857f7def615b
--- /dev/null
+++ b/x11-misc/trayer-srg/trayer-srg-1.1.8-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="trayer fork with multi monitor support and cleaned up codebase"
+HOMEPAGE="https://github.com/sargon/trayer-srg"
+SRC_URI="https://github.com/sargon/${PN}/archive/${P/-srg/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ x11-libs/gdk-pixbuf:2
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${PN}-trayer-${PV}
+
+src_configure() {
+ ./configure --prefix="${EPREFIX}" || die
+}
+
+src_compile() {
+ emake TARGET=${PN} CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}