summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild')
-rw-r--r--x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild b/x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild
index 03384930c47f..610ab7161a8d 100644
--- a/x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild
+++ b/x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit flag-o-matic
+
DESCRIPTION="Control a remote computer running VNC from X"
HOMEPAGE="https://fredrik.hubbe.net/x2vnc.html"
SRC_URI="https://fredrik.hubbe.net/x2vnc/${P}.tar.gz"
@@ -31,6 +33,12 @@ PATCHES=(
"${FILESDIR}"/${P}-clang16.patch
)
+src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
+ default
+}
+
src_install() {
dodir /usr/share /usr/bin
emake DESTDIR="${D}" install