summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xosview')
-rw-r--r--x11-misc/xosview/Manifest1
-rw-r--r--x11-misc/xosview/xosview-1.21.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-misc/xosview/Manifest b/x11-misc/xosview/Manifest
index 124e9ee57cd8..394b8f267253 100644
--- a/x11-misc/xosview/Manifest
+++ b/x11-misc/xosview/Manifest
@@ -1 +1,2 @@
DIST xosview-1.20.tar.gz 146373 BLAKE2B 7d53b5f2f8ce463917a1cfa65eedb60c835c6d530a19ede6bba6bfe295a01582861ca3fb7513b9a8590d9fe5111779a38db8723a2e38c911f002bce88bfc95f6 SHA512 25cd6a8cdaaff9121f0e8de7a1799d4c2706c5eb1111f3b3f8427b16e45a333fb4c675a1dec2ef6b40773e83124ff27eacc82f2b9eb6c836855930cbbf08957a
+DIST xosview-1.21.tar.gz 146428 BLAKE2B 899e0cb68489bd02e035765f8f33424d41996b80a7c16651f60a2e46538cf4eac1a9377342c2ed4f35da6cb00aa3961e34802c77fe26e4743a23e2d3dc443484 SHA512 9c42247d9e9b391b94c18ffc8c38df414f5293b7426aa57d3b357e680b02e9a3a2b332299905f2f529d488c23590e957cad9e088ddf753a6904905e2dff8074b
diff --git a/x11-misc/xosview/xosview-1.21.ebuild b/x11-misc/xosview/xosview-1.21.ebuild
new file mode 100644
index 000000000000..a88949d99bbb
--- /dev/null
+++ b/x11-misc/xosview/xosview-1.21.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils toolchain-funcs xdg-utils
+
+DESCRIPTION="X11 operating system viewer"
+HOMEPAGE="http://www.pogo.org.uk/~mark/xosview/"
+SRC_URI="http://www.pogo.org.uk/~mark/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="suid"
+
+COMMON_DEPS="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt"
+RDEPEND="${COMMON_DEPS}
+ media-fonts/font-misc-misc"
+DEPEND="${COMMON_DEPS}
+ x11-base/xorg-proto"
+
+DOCS=( CHANGES README.linux TODO )
+
+src_prepare() {
+ default
+
+ sed -i -e 's:lib/X11/app:share/X11/app:g' -i ${PN}.1 || die
+ sed -i -e "s:Git:${PV}:g" ${PN}.cc || die
+ tc-export CXX
+}
+
+src_compile() {
+ emake OPTFLAGS=''
+}
+
+src_install() {
+ emake PREFIX="${D%/}/usr" install
+ use suid && fperms 4755 /usr/bin/${PN}
+ insinto /usr/share/X11/app-defaults
+ newins Xdefaults XOsview
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ if ! use suid ; then
+ ewarn "If you want to use serial meters ${PN} needs to be executed as root."
+ ewarn "Please see ${EPREFIX}/usr/share/doc/${PF}/README.linux for details."
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}