summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xsri')
-rw-r--r--x11-misc/xsri/files/xsri-2.1.0-configure.patch2
-rw-r--r--x11-misc/xsri/xsri-2.1.0_p17_p12.ebuild46
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-misc/xsri/files/xsri-2.1.0-configure.patch b/x11-misc/xsri/files/xsri-2.1.0-configure.patch
index c000e7091092..d7a92f9c9fb2 100644
--- a/x11-misc/xsri/files/xsri-2.1.0-configure.patch
+++ b/x11-misc/xsri/files/xsri-2.1.0-configure.patch
@@ -16,7 +16,7 @@
dnl library checks (not using macros/ directory)
-PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 1.3.13,,
-+PKG_CHECK_MODULES(GTK, x11 gtk+-2.0 >= 1.3.13,,
++PKG_CHECK_MODULES(GTK, x11 gtk+-2.0 >= 1.3.13 gdk-pixbuf-2.0,,
AC_MSG_ERROR([*** GTK+-2.0 must be installed to compile xsri]))
+AC_CHECK_LIB(m, sqrt)
diff --git a/x11-misc/xsri/xsri-2.1.0_p17_p12.ebuild b/x11-misc/xsri/xsri-2.1.0_p17_p12.ebuild
new file mode 100644
index 000000000000..c72349d5799a
--- /dev/null
+++ b/x11-misc/xsri/xsri-2.1.0_p17_p12.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools eutils rpm
+
+DESCRIPTION="The xsri wallpaper setter from RedHat"
+HOMEPAGE="https://fedoraproject.org"
+SRC_URI="
+ https://download.fedoraproject.org/pub/fedora/linux/releases/$(ver_cut 7)/Everything/source/SRPMS/${P/_p*/}-$(ver_cut 5).fc$(ver_cut 7).src.rpm
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${P/_p*/}-configure.patch
+)
+S=${WORKDIR}/${P/_p*/}
+DOCS=( AUTHORS ChangeLog README )
+
+src_unpack() {
+ rpm_unpack
+ unpack "${WORKDIR}"/${P/_p*/}.tar.gz
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ doman ../${PN}.1
+}