summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xystray/xystray-1.0-r1.ebuild')
-rw-r--r--x11-misc/xystray/xystray-1.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-misc/xystray/xystray-1.0-r1.ebuild b/x11-misc/xystray/xystray-1.0-r1.ebuild
new file mode 100644
index 000000000000..0479175fa362
--- /dev/null
+++ b/x11-misc/xystray/xystray-1.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A simple implementation of freedesktop.org notification area for X"
+HOMEPAGE="https://steelman.github.io/xystray/"
+SRC_URI="https://github.com/steelman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-libs/libXaw"
+
+PATCHES=(
+ "${FILESDIR}/${P}-ldflags.patch"
+)
+
+src_install() {
+ dobin xystray
+}