summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/zim')
-rw-r--r--x11-misc/zim/Manifest1
-rw-r--r--x11-misc/zim/zim-0.73.2.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/x11-misc/zim/Manifest b/x11-misc/zim/Manifest
index e058e0dcfa75..2b4146fb76fd 100644
--- a/x11-misc/zim/Manifest
+++ b/x11-misc/zim/Manifest
@@ -1 +1,2 @@
DIST zim-0.73.1.tar.gz 2615382 BLAKE2B 055857b20dbdebc1e5d8d6b13c344fcf665d9889f392f9c58fd3cfef1f80865a78c48e5138d2443f67bb29b8cd915b8d0d6bc0ac4807de20344dfe6673f1350e SHA512 ba67b396a6c06921e5e67ab5ccf0559e54b29a719262411b24f178c350bd0ac7c8239f8d5d4396b9dc291aadc36b59869d81dc04d457ce4a36eade67cdd53dd2
+DIST zim-0.73.2.tar.gz 2611490 BLAKE2B 05fd020b3add3ac9c6fd860ca002a5c0755a1a1f1ee07c6e5027e16e3b8c64d9116971e96ed235b249b65b9097551b9fcdf46ed929a03a877c36a02a7d54e8fd SHA512 26c987906759436063f88863e90cf2643996913a2fae12ebc4ae623731ad97d488d37ad70e72153aba7aaac7fe2dff9bb6f9f06c4d899a0ac20e3bfbd20ff3db
diff --git a/x11-misc/zim/zim-0.73.2.ebuild b/x11-misc/zim/zim-0.73.2.ebuild
new file mode 100644
index 000000000000..979b6c32c161
--- /dev/null
+++ b/x11-misc/zim/zim-0.73.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+inherit xdg-utils virtualx distutils-r1
+
+DESCRIPTION="A desktop wiki"
+HOMEPAGE="
+ https://zim-wiki.org/
+ https://github.com/zim-desktop-wiki/zim-desktop-wiki
+"
+SRC_URI="https://github.com/${PN}-desktop-wiki/${PN}-desktop-wiki/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ ')
+ x11-libs/gtk+:3[introspection]
+ x11-misc/xdg-utils
+"
+DEPEND="
+ ${RDEPEND}
+"
+DOCS=( CHANGELOG.md CONTRIBUTING.md PLUGIN_WRITING.md README.md )
+PATCHES=( "${FILESDIR}"/${PN}-0.60-remove-ubuntu-theme.patch )
+S=${WORKDIR}/${PN}-desktop-wiki-${PV/_/-}
+
+python_prepare_all() {
+ sed -i -e "s/'USER'/'LOGNAME'/g" zim/__init__.py zim/fs.py || die
+
+ if [[ ${LINGUAS} ]]; then
+ local lingua
+ for lingua in translations/*.po; do
+ lingua=${lingua/.po}
+ lingua=${lingua/translations\/}
+ has ${lingua} ${LINGUAS} || \
+ { rm translations/${lingua}.po || die; }
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+ export XDG_RUNTIME_DIR=fakethis
+}
+
+python_install() {
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ if ! has_version ${CATEGORY}/${PN}; then
+ elog "Please install these packages for additional functionality"
+ elog " dev-lang/R"
+ elog " dev-python/gtkspell-python"
+ elog " dev-vcs/bzr"
+ elog " media-gfx/graphviz"
+ elog " media-gfx/imagemagick"
+ elog " media-gfx/scrot"
+ elog " media-sound/lilypond"
+ elog " sci-visualization/gnuplot"
+ elog " virtual/latex-base app-text/dvipng"
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}