summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/bumblebee/bumblebee-3.2.1_p20210112-r4.ebuild12
-rw-r--r--x11-misc/bumblebee/bumblebee-9999.ebuild12
2 files changed, 20 insertions, 4 deletions
diff --git a/x11-misc/bumblebee/bumblebee-3.2.1_p20210112-r4.ebuild b/x11-misc/bumblebee/bumblebee-3.2.1_p20210112-r4.ebuild
index 25bad11dfede..b0690088fc3a 100644
--- a/x11-misc/bumblebee/bumblebee-3.2.1_p20210112-r4.ebuild
+++ b/x11-misc/bumblebee/bumblebee-3.2.1_p20210112-r4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools readme.gentoo-r1 systemd
+inherit autotools readme.gentoo-r1 systemd udev
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -91,3 +91,11 @@ src_install() {
You may need to setup your /etc/bumblebee/bumblebee.conf"
readme.gentoo_create_doc
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/x11-misc/bumblebee/bumblebee-9999.ebuild b/x11-misc/bumblebee/bumblebee-9999.ebuild
index 4c2cecf46ce5..bd63a8594628 100644
--- a/x11-misc/bumblebee/bumblebee-9999.ebuild
+++ b/x11-misc/bumblebee/bumblebee-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools readme.gentoo-r1 systemd
+inherit autotools readme.gentoo-r1 systemd udev
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -91,3 +91,11 @@ src_install() {
You may need to setup your /etc/bumblebee/bumblebee.conf"
readme.gentoo_create_doc
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}