summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/asmon/files')
-rw-r--r--x11-plugins/asmon/files/asmon-0.7.cflags.diff31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/asmon/files/asmon-0.7.cflags.diff b/x11-plugins/asmon/files/asmon-0.7.cflags.diff
new file mode 100644
index 000000000000..b69c692abb90
--- /dev/null
+++ b/x11-plugins/asmon/files/asmon-0.7.cflags.diff
@@ -0,0 +1,31 @@
+--- asmon/Makefile.orig 1999-06-26 03:35:13.000000000 +0200
++++ asmon/Makefile 2006-08-24 20:21:52.000000000 +0200
+@@ -4,7 +4,7 @@
+ #SOLARIS_LIBS = -lsocket -lkstat
+ #SOLARIS_OBJS = solaris26.o
+
+-LIBDIR = -L/usr/X11R6/lib
++LIBDIR = -L/usr/lib
+ LIBS = -lXpm -lXext -lX11 $(SOLARIS_LIBS)
+ OBJS = asmon.o $(SOLARIS_OBJS) \
+ ../wmgeneral/wmgeneral.o \
+@@ -12,16 +12,16 @@
+ ../wmgeneral/list.o
+
+ .c.o:
+- gcc -c -Wall $(SOLARIS) $< -o $*.o
++ gcc -c -Wall $(CFLAGS) $(SOLARIS) $< -o $*.o
+
+ asmon: $(OBJS)
+ gcc -o asmon $(OBJS) $(LIBDIR) $(LIBS)
+
+ clean::
+ for i in $(OBJS) ; do \
+- rm $$i;\
++ rm -f $$i;\
+ done
+- rm asmon
++ rm -f asmon
+
+ install::
+ cp -f asmon /usr/local/bin