summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0-r1.ebuild')
-rw-r--r--x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0-r1.ebuild b/x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0-r1.ebuild
index 05c5ee785dea..4e2f936ff6f6 100644
--- a/x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0-r1.ebuild
+++ b/x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
MY_P=${P/-ac}
DESCRIPTION="WMACPILoad based dockapp to monitor CPU temp and battery time on ACPI kernels"
@@ -11,7 +13,7 @@ SRC_URI="http://wmacpiload.tuxfamily.org/download/${MY_P}.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 x86"
IUSE="debug"
RDEPEND="x11-libs/libX11
@@ -30,6 +32,11 @@ PATCHES=(
"${FILESDIR}/${PN}-acpi-fix-battery-unit.patch"
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf $(use_enable debug)
}