summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmhdplop/wmhdplop-0.9.10.ebuild')
-rw-r--r--x11-plugins/wmhdplop/wmhdplop-0.9.10.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/wmhdplop/wmhdplop-0.9.10.ebuild b/x11-plugins/wmhdplop/wmhdplop-0.9.10.ebuild
new file mode 100644
index 000000000000..bf6be8be3671
--- /dev/null
+++ b/x11-plugins/wmhdplop/wmhdplop-0.9.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="a dockapp for monitoring disk activities with fancy visuals"
+HOMEPAGE="http://www.dockapps.net/wmhdplop"
+SRC_URI="http://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/imlib2[X]
+ x11-libs/libX11
+ x11-libs/libXext
+ media-fonts/corefonts
+ >=media-libs/freetype-2"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.9-64bit.patch
+ "${FILESDIR}"/${P}-cflags.patch
+ )
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ eautoreconf
+ default
+}
+
+src_configure() {
+ econf --disable-gkrellm
+}