summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmlife/wmlife-1.0.1.ebuild')
-rw-r--r--x11-plugins/wmlife/wmlife-1.0.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-plugins/wmlife/wmlife-1.0.1.ebuild b/x11-plugins/wmlife/wmlife-1.0.1.ebuild
new file mode 100644
index 000000000000..82e9986d3f04
--- /dev/null
+++ b/x11-plugins/wmlife/wmlife-1.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="dockapp running Conway's Game of Life (and program launcher)"
+HOMEPAGE="http://www.swanson.ukfsn.org/#wmlife"
+SRC_URI="http://www.swanson.ukfsn.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext"
+EPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.0.0-stringh.patch
+ "${FILESDIR}"/${P}-configure.patch )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.0-stringh.patch
+ epatch "${FILESDIR}"/${P}-configure.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-session
+}