summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmload/wmload-0.9.7.ebuild')
-rw-r--r--x11-plugins/wmload/wmload-0.9.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/wmload/wmload-0.9.7.ebuild b/x11-plugins/wmload/wmload-0.9.7.ebuild
new file mode 100644
index 000000000000..b93192579eb5
--- /dev/null
+++ b/x11-plugins/wmload/wmload-0.9.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="yet another dock application showing a system load gauge"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmload"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9.6-solaris.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+
+ dodoc README
+ domenu "${FILESDIR}"/${PN}.desktop
+}