summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmmisc/files/wmmisc-1.1-build.patch')
-rw-r--r--x11-plugins/wmmisc/files/wmmisc-1.1-build.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-plugins/wmmisc/files/wmmisc-1.1-build.patch b/x11-plugins/wmmisc/files/wmmisc-1.1-build.patch
new file mode 100644
index 000000000000..d42400ab0132
--- /dev/null
+++ b/x11-plugins/wmmisc/files/wmmisc-1.1-build.patch
@@ -0,0 +1,48 @@
+diff -ur wmmisc-1.1.orig/src/general.mk wmmisc-1.1/src/general.mk
+--- wmmisc-1.1.orig/src/general.mk 2006-01-07 19:50:31.000000000 +0200
++++ wmmisc-1.1/src/general.mk 2008-01-16 20:44:59.000000000 +0200
+@@ -16,7 +16,7 @@
+ MANDIR = $(PREFIX)/share/man
+ # Set some destination locations.
+
+-CC = gcc
++CC ?= gcc
+ CXX = g++
+ # Set the compilers.
+
+@@ -45,13 +45,7 @@
+ # Set the assembler and flags.
+
+ LD = ld
+-LDFLAGS = -lm
+-ifeq ($(MODULAR_X),1)
+-LDFLAGS += $(shell pkg-config --libs x11 xpm xext)
+-else
+-LDFLAGS += -L/usr/X11R6/lib -lX11 -lXpm -lXext
+-endif
+-LDFLAGS += -Wl,-O1
++LIBS = -lm -lX11 -lXpm -lXext
+ # Set the linker and flags.
+
+ AR = ar
+@@ -64,7 +58,7 @@
+ ifeq ($(MODULAR_X),1)
+ INCLUDES = $(shell pkg-config --cflags x11 xpm xext)
+ else
+-INCLUDES = -I/usr/X11R6/include
++INCLUDES = -I/usr/include
+ endif
+ INCLUDES += -I.
+ # Set the include locations.
+diff -ur wmmisc-1.1.orig/src/Makefile wmmisc-1.1/src/Makefile
+--- wmmisc-1.1.orig/src/Makefile 2006-01-07 20:45:59.000000000 +0200
++++ wmmisc-1.1/src/Makefile 2008-01-16 20:43:31.000000000 +0200
+@@ -23,7 +23,7 @@
+
+ $(package): $(objects)
+ rm -f $(package)
+- $(CC) $(CFLAGS) -o $(package) $(objects) $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $(package) $(objects) $(LIBS)
+
+ wmgeneral.o: wmgeneral.c wmgeneral.h
+ rm -f wmgeneral.o