summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmmon')
-rw-r--r--x11-plugins/wmmon/Manifest2
-rw-r--r--x11-plugins/wmmon/files/wmmon-1.2_beta1-Makefile.patch20
-rw-r--r--x11-plugins/wmmon/files/wmmon-1.2_beta1-list.patch127
-rw-r--r--x11-plugins/wmmon/wmmon-1.2_beta1.ebuild37
-rw-r--r--x11-plugins/wmmon/wmmon-1.3.ebuild19
5 files changed, 0 insertions, 205 deletions
diff --git a/x11-plugins/wmmon/Manifest b/x11-plugins/wmmon/Manifest
index cb7b119b5575..b4be83dc420a 100644
--- a/x11-plugins/wmmon/Manifest
+++ b/x11-plugins/wmmon/Manifest
@@ -1,3 +1 @@
-DIST wmmon-1.2b1.tar.bz2 25610 BLAKE2B fcaf37c869e5cfc9c105c1924f66a03a726239ef5a6c473a312a8d8e4bd34203fa71d6ded607894b0feae1f4a352c365828dba284c629c81dea0973b05ad98b8 SHA512 359ff4024cdc606d3520445d31b9e59c79a957b081bf46dfabde7c970aecab8d640f789f34c1599e18e15e50a077248e06600151d7c1e66ef028215d6d88ff1f
-DIST wmmon-1.3.tar.gz 107622 BLAKE2B 41eabaf506882f9e230ffd5bcb2c28325b49a1594423f9e950941b5f3a343ceee19bd22c91a29d62a4eaeee920fba19caf1fcb7656db646cb464a9ec6d1a1890 SHA512 2308bf5ef9aa9f93979e63ea7d405e304a1a7ea55b966affc200239829f3cd2b7039fe96e42fcf59b52dddd5a72b3f8f64d8397853c3847356733644045e5529
DIST wmmon-1.4.tar.gz 107477 BLAKE2B 973dedb994c0e688dbdcefde12d186e1d3712164adeb454e97367c6592e223dd61f01ddc7c5258bc387619ed185f049439b8692a18a1bd28bccafda986359e36 SHA512 ca5a0d8278d6fda4ae1be2e76e17ad7e550e91398dba1c5aa09b501c4e17b8d4f597bcaa0c9ea844d3a307a5c60d6d28e44cbffd54fe44c92be0386450f25951
diff --git a/x11-plugins/wmmon/files/wmmon-1.2_beta1-Makefile.patch b/x11-plugins/wmmon/files/wmmon-1.2_beta1-Makefile.patch
deleted file mode 100644
index c7633ad7388b..000000000000
--- a/x11-plugins/wmmon/files/wmmon-1.2_beta1-Makefile.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- wmmon/Makefile.orig 2012-03-29 13:17:39.380764054 +0200
-+++ wmmon/Makefile 2012-03-29 13:18:06.623931767 +0200
-@@ -6,14 +6,14 @@
- ../wmgeneral/list.o
-
- CFLAGS = -O2
--CC = cc $(CFLAGS)
-+CC = cc
-
-
- .c.o:
-- $(CC) -c -Wall $< -o $*.o
-+ $(CC) $(CFLAGS) -c -Wall $< -o $*.o
-
- wmmon: $(OBJS)
-- $(CC) -o wmmon $^ $(LIBDIR) $(LIBS)
-+ $(CC) $(LDFLAGS) -o wmmon $^ $(LIBDIR) $(LIBS)
-
- debug: CFLAGS = -g3
- debug: wmmon
diff --git a/x11-plugins/wmmon/files/wmmon-1.2_beta1-list.patch b/x11-plugins/wmmon/files/wmmon-1.2_beta1-list.patch
deleted file mode 100644
index 1b1ac317669e..000000000000
--- a/x11-plugins/wmmon/files/wmmon-1.2_beta1-list.patch
+++ /dev/null
@@ -1,127 +0,0 @@
-diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
---- wmgeneral.orig/list.c 2016-01-04 13:28:36.583339716 +0100
-+++ wmgeneral/list.c 2016-01-04 13:28:48.694343645 +0100
-@@ -38,7 +38,7 @@
-
- /* Return a cons cell produced from (head . tail)
-
--INLINE LinkedList*
-+LinkedList*
- list_cons(void* head, LinkedList* tail)
- {
- LinkedList* cell;
-@@ -51,7 +51,7 @@
-
- /* Return the length of a list, list_length(NULL) returns zero
-
--INLINE int
-+int
- list_length(LinkedList* list)
- {
- int i = 0;
-@@ -66,7 +66,7 @@
- /* Return the Nth element of LIST, where N count from zero. If N
- larger than the list length, NULL is returned
-
--INLINE void*
-+void*
- list_nth(int index, LinkedList* list)
- {
- while(index-- != 0)
-@@ -81,7 +81,7 @@
-
- /* Remove the element at the head by replacing it by its successor
-
--INLINE void
-+void
- list_remove_head(LinkedList** list)
- {
- if (!*list) return;
-@@ -101,7 +101,7 @@
-
- /* Remove the element with `car' set to ELEMENT
- /*
--INLINE void
-+void
- list_remove_elem(LinkedList** list, void* elem)
- {
- while (*list)
-@@ -112,7 +112,7 @@
- }
-
-
--INLINE LinkedList *
-+LinkedList *
- list_remove_elem(LinkedList* list, void* elem)
- {
- LinkedList *tmp;
-@@ -132,7 +132,7 @@
-
- /* Return element that has ELEM as car
-
--INLINE LinkedList*
-+LinkedList*
- list_find(LinkedList* list, void* elem)
- {
- while(list)
-@@ -146,7 +146,7 @@
-
- /* Free list (backwards recursive)
-
--INLINE void
-+void
- list_free(LinkedList* list)
- {
- if(list)
-@@ -158,7 +158,7 @@
-
- /* Map FUNCTION over all elements in LIST
-
--INLINE void
-+void
- list_mapcar(LinkedList* list, void(*function)(void*))
- {
- while(list)
-diff -Naur wmgeneral.orig/list.h wmgeneral/list.h
---- wmgeneral.orig/list.h 2016-01-04 13:28:36.583339716 +0100
-+++ wmgeneral/list.h 2016-01-04 13:28:39.471340654 +0100
-@@ -29,31 +29,25 @@
- #ifndef __LIST_H_
- #define __LIST_H_
-
--#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
--# define INLINE inline
--#else
--# define INLINE
--#endif
--
- typedef struct LinkedList {
- void *head;
- struct LinkedList *tail;
- } LinkedList;
-
--INLINE LinkedList* list_cons(void* head, LinkedList* tail);
-+LinkedList* list_cons(void* head, LinkedList* tail);
-
--INLINE int list_length(LinkedList* list);
-+int list_length(LinkedList* list);
-
--INLINE void* list_nth(int index, LinkedList* list);
-+void* list_nth(int index, LinkedList* list);
-
--INLINE void list_remove_head(LinkedList** list);
-+void list_remove_head(LinkedList** list);
-
--INLINE LinkedList *list_remove_elem(LinkedList* list, void* elem);
-+LinkedList *list_remove_elem(LinkedList* list, void* elem);
-
--INLINE void list_mapcar(LinkedList* list, void(*function)(void*));
-+void list_mapcar(LinkedList* list, void(*function)(void*));
-
--INLINE LinkedList*list_find(LinkedList* list, void* elem);
-+LinkedList*list_find(LinkedList* list, void* elem);
-
--INLINE void list_free(LinkedList* list);
-+void list_free(LinkedList* list);
-
- #endif
diff --git a/x11-plugins/wmmon/wmmon-1.2_beta1.ebuild b/x11-plugins/wmmon/wmmon-1.2_beta1.ebuild
deleted file mode 100644
index a0ba35afd5ac..000000000000
--- a/x11-plugins/wmmon/wmmon-1.2_beta1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Dockable system resources monitor applet for WindowMaker"
-HOMEPAGE="https://www.dockapps.net/wmmon"
-SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P/_beta/b}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc sparc x86"
-IUSE=""
-
-RDEPEND="x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXpm"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-
-S=${WORKDIR}/${P/_beta/b}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-Makefile.patch
- epatch "${FILESDIR}"/${P}-list.patch
-}
-
-src_compile() {
- emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" -C ${PN}
-}
-
-src_install () {
- dobin wmmon/wmmon
- doman wmmon/wmmon.1
- dodoc BUGS CHANGES HINTS README TODO
-}
diff --git a/x11-plugins/wmmon/wmmon-1.3.ebuild b/x11-plugins/wmmon/wmmon-1.3.ebuild
deleted file mode 100644
index 921742857e86..000000000000
--- a/x11-plugins/wmmon/wmmon-1.3.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Dockable system resources monitor applet for WindowMaker"
-HOMEPAGE="https://www.dockapps.net/wmmon"
-SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
-
-RDEPEND=">=x11-libs/libdockapp-0.7:=
- x11-libs/libX11
- x11-libs/libXpm"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"