summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmweather+/files/wmweather+-2.17-gcc-10.patch23
-rw-r--r--x11-plugins/wmweather+/wmweather+-2.17.ebuild4
2 files changed, 26 insertions, 1 deletions
diff --git a/x11-plugins/wmweather+/files/wmweather+-2.17-gcc-10.patch b/x11-plugins/wmweather+/files/wmweather+-2.17-gcc-10.patch
new file mode 100644
index 000000000000..1b26aa3936e5
--- /dev/null
+++ b/x11-plugins/wmweather+/files/wmweather+-2.17-gcc-10.patch
@@ -0,0 +1,23 @@
+diff -Naur wmweather+-2.17.orig/wmgeneral/wmgeneral-x11.c wmweather+-2.17/wmgeneral/wmgeneral-x11.c
+--- wmweather+-2.17.orig/wmgeneral/wmgeneral-x11.c 2014-02-07 20:17:44.000000000 +0100
++++ wmweather+-2.17/wmgeneral/wmgeneral-x11.c 2020-02-24 22:11:47.226905019 +0100
+@@ -94,6 +94,7 @@
+ GC NormalGC;
+ GC RedrawGC;
+ XpmIcon wmgen;
++Display *display;
+
+ /***********************/
+ /* Function Prototypes */
+diff -Naur wmweather+-2.17.orig/wmgeneral/wmgeneral-x11.h wmweather+-2.17/wmgeneral/wmgeneral-x11.h
+--- wmweather+-2.17.orig/wmgeneral/wmgeneral-x11.h 2014-02-07 20:17:44.000000000 +0100
++++ wmweather+-2.17/wmgeneral/wmgeneral-x11.h 2020-02-24 22:10:45.233884234 +0100
+@@ -17,7 +17,7 @@
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
diff --git a/x11-plugins/wmweather+/wmweather+-2.17.ebuild b/x11-plugins/wmweather+/wmweather+-2.17.ebuild
index 49e62aa1ecf9..94bc2487217f 100644
--- a/x11-plugins/wmweather+/wmweather+-2.17.ebuild
+++ b/x11-plugins/wmweather+/wmweather+-2.17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,3 +19,5 @@ DEPEND="dev-libs/libpcre
x11-libs/libX11
x11-wm/windowmaker"
RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc-10.patch )