summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmbiff/files/wmbiff-0.4.35-fno-common.patch24
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.35.ebuild7
2 files changed, 29 insertions, 2 deletions
diff --git a/x11-plugins/wmbiff/files/wmbiff-0.4.35-fno-common.patch b/x11-plugins/wmbiff/files/wmbiff-0.4.35-fno-common.patch
new file mode 100644
index 000000000000..2320f17143de
--- /dev/null
+++ b/x11-plugins/wmbiff/files/wmbiff-0.4.35-fno-common.patch
@@ -0,0 +1,24 @@
+diff -Naur wmbiff-0.4.35.orig/wmbiff/wmbiff.c wmbiff-0.4.35/wmbiff/wmbiff.c
+--- wmbiff-0.4.35.orig/wmbiff/wmbiff.c 2019-07-23 15:58:58.000000000 +0200
++++ wmbiff-0.4.35/wmbiff/wmbiff.c 2020-03-08 12:25:32.766264038 +0100
+@@ -104,6 +104,8 @@
+
+ Cursor busy_cursor, ready_cursor;
+
++Display *display;
++
+ static __inline /*@out@ */ void *
+ malloc_ordie(size_t len)
+ {
+diff -Naur wmbiff-0.4.35.orig/wmgeneral/wmgeneral.h wmbiff-0.4.35/wmgeneral/wmgeneral.h
+--- wmbiff-0.4.35.orig/wmgeneral/wmgeneral.h 2019-07-23 15:57:57.000000000 +0200
++++ wmbiff-0.4.35/wmgeneral/wmgeneral.h 2020-03-08 12:25:16.223256712 +0100
+@@ -36,7 +36,7 @@
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.35.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.35.ebuild
index 4c3609d57973..9200caafc51c 100644
--- a/x11-plugins/wmbiff/wmbiff-0.4.35.ebuild
+++ b/x11-plugins/wmbiff/wmbiff-0.4.35.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,10 +25,13 @@ DEPEND="${RDEPEND}
BDEPEND="virtual/pkgconfig"
DOCS="ChangeLog FAQ NEWS README TODO wmbiff/sample.wmbiffrc"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.27-invalid-strncpy.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ )
src_prepare() {
default
- eapply "${FILESDIR}"/${PN}-0.4.27-invalid-strncpy.patch
eautoreconf
}