summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/lxqt-themes/lxqt-themes-1.1.0.ebuild')
-rw-r--r--x11-themes/lxqt-themes/lxqt-themes-1.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-themes/lxqt-themes/lxqt-themes-1.1.0.ebuild b/x11-themes/lxqt-themes/lxqt-themes-1.1.0.ebuild
new file mode 100644
index 000000000000..825b9044bb24
--- /dev/null
+++ b/x11-themes/lxqt-themes/lxqt-themes-1.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="LXQt Themes"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.11.0"
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}