summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/mate-themes/mate-themes-3.22.21.ebuild')
-rw-r--r--x11-themes/mate-themes/mate-themes-3.22.21.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-themes/mate-themes/mate-themes-3.22.21.ebuild b/x11-themes/mate-themes/mate-themes-3.22.21.ebuild
new file mode 100644
index 000000000000..10b46ff615eb
--- /dev/null
+++ b/x11-themes/mate-themes/mate-themes-3.22.21.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+MATE_GTK_V="$(ver_cut 1-2)"
+
+HOMEPAGE="https://mate-desktop.org"
+DESCRIPTION="A set of MATE themes, with sets for users with limited or low vision"
+SRC_URI="https://pub.mate-desktop.org/releases/themes/${MATE_GTK_V}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0/${MATE_GTK_V}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=x11-libs/gdk-pixbuf-2:2
+ >=x11-libs/gtk+-2:2
+ >=x11-themes/gtk-engines-2.15.3:2
+ x11-themes/gtk-engines-murrine
+"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.19.8:*
+ >=sys-devel/autoconf-2.53
+ >=x11-misc/icon-naming-utils-0.8.7:0
+ virtual/pkgconfig
+"
+
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ default
+ eautoreconf
+}