summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/ubuntu-wallpapers/Manifest1
-rw-r--r--x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-18.10.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-themes/ubuntu-wallpapers/Manifest b/x11-themes/ubuntu-wallpapers/Manifest
index 00d5e9bf39d6..fb075c39b4a2 100644
--- a/x11-themes/ubuntu-wallpapers/Manifest
+++ b/x11-themes/ubuntu-wallpapers/Manifest
@@ -1 +1,2 @@
DIST ubuntu-wallpapers_18.04.1.orig.tar.gz 167057924 BLAKE2B 0d1bd7dc96d3a1ddc3becaa775a6da47645d5962cbcc49e4cab8430adef6ff5c13248b7eb88b1394c80fa5e1b53f8aff94b15b3c7ba836fcc5d94ea86e02572e SHA512 ad46d79cc32315f67f244bfabb74188478c43374d3021e20d0f0d4182cff7f93920df2fae141257695148dc0d69d8e4e0fa486ac616e6256e9269c8b5d6e06d6
+DIST ubuntu-wallpapers_18.10.2.orig.tar.gz 186856866 BLAKE2B 4cc8f3f0e95bdc28d25d5b664678b60b924d2fbbd0876c260f45320bcb64bec4ddb3889c16b1bba1fc2506eba5ce579987a9cf8b25c3748a1c4529b52813c64c SHA512 dadd84e0b0d6be010254577239001d423b06730690cce44031ec90b1c7fe28312afb0720f8da7758f069b81556662f8a3c231c50255695090bc932d3ec9496db
diff --git a/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-18.10.2.ebuild b/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-18.10.2.ebuild
new file mode 100644
index 000000000000..f302875b2504
--- /dev/null
+++ b/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-18.10.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Ubuntu wallpapers"
+HOMEPAGE="https://launchpad.net/ubuntu/+source/ubuntu-wallpapers"
+MY_P="${PN}_${PV}"
+SRC_URI="mirror://ubuntu/pool/main/u/${PN}/${MY_P}.orig.tar.gz"
+LICENSE="CC-BY-SA-3.0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}/${MY_P/_/-}"
+
+SLOT="0"
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/backgrounds
+ doins *.jpg *.png
+
+ insinto /usr/share/backgrounds/contest
+ doins contest/*.xml
+
+ for i in *.xml.in; do
+ insinto /usr/share/gnome-background-properties
+ newins ${i} ${i/.in/}
+ done
+
+ einstalldocs
+}