summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/herbstluftwm')
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-0.8.3.ebuild31
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-9999.ebuild32
2 files changed, 26 insertions, 37 deletions
diff --git a/x11-wm/herbstluftwm/herbstluftwm-0.8.3.ebuild b/x11-wm/herbstluftwm/herbstluftwm-0.8.3.ebuild
index 716b6043cb68..a27ee0ea3e0d 100644
--- a/x11-wm/herbstluftwm/herbstluftwm-0.8.3.ebuild
+++ b/x11-wm/herbstluftwm/herbstluftwm-0.8.3.ebuild
@@ -4,22 +4,14 @@
EAPI=7
inherit toolchain-funcs cmake-utils
-if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/herbstluftwm/herbstluftwm"
- BDEPEND="app-text/asciidoc"
-else
- SRC_URI="https://herbstluftwm.org/tarballs/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- BDEPEND=""
-fi
-
DESCRIPTION="A manual tiling window manager for X"
HOMEPAGE="https://herbstluftwm.org/"
+SRC_URI="https://herbstluftwm.org/tarballs/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
LICENSE="BSD-2"
SLOT="0"
-IUSE="examples zsh-completion"
+IUSE="doc examples"
DEPEND="
x11-libs/libX11
@@ -30,17 +22,24 @@ DEPEND="
RDEPEND="
${DEPEND}
app-shells/bash
- zsh-completion? ( app-shells/zsh )
"
-BDEPEND+="
+BDEPEND="
virtual/pkgconfig
+ doc? ( app-text/asciidoc )
"
-src_configure() {
+src_prepare() {
sed -i \
-e '/^install.*LICENSEDIR/d' \
-e '/set(DOCDIR / s#.*#set(DOCDIR ${CMAKE_INSTALL_DOCDIR})#' \
CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_DOCUMENTATION=$(usex doc)
+ )
cmake-utils_src_configure
}
@@ -51,8 +50,4 @@ src_install() {
if ! use examples; then
rm -r "${ED}"/usr/share/doc/${PF}/examples || die
fi
-
- if ! use zsh-completion; then
- rm -r "${ED}"/usr/share/zsh || die
- fi
}
diff --git a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
index 716b6043cb68..4ebb6b1f0ad3 100644
--- a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
+++ b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
@@ -2,24 +2,15 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs cmake-utils
-
-if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/herbstluftwm/herbstluftwm"
- BDEPEND="app-text/asciidoc"
-else
- SRC_URI="https://herbstluftwm.org/tarballs/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- BDEPEND=""
-fi
+inherit git-r3 toolchain-funcs cmake-utils
DESCRIPTION="A manual tiling window manager for X"
HOMEPAGE="https://herbstluftwm.org/"
+EGIT_REPO_URI="https://github.com/herbstluftwm/herbstluftwm"
LICENSE="BSD-2"
SLOT="0"
-IUSE="examples zsh-completion"
+IUSE="doc examples"
DEPEND="
x11-libs/libX11
@@ -30,17 +21,24 @@ DEPEND="
RDEPEND="
${DEPEND}
app-shells/bash
- zsh-completion? ( app-shells/zsh )
"
-BDEPEND+="
+BDEPEND="
virtual/pkgconfig
+ doc? ( app-text/asciidoc )
"
-src_configure() {
+src_prepare() {
sed -i \
-e '/^install.*LICENSEDIR/d' \
-e '/set(DOCDIR / s#.*#set(DOCDIR ${CMAKE_INSTALL_DOCDIR})#' \
CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_DOCUMENTATION=$(usex doc)
+ )
cmake-utils_src_configure
}
@@ -51,8 +49,4 @@ src_install() {
if ! use examples; then
rm -r "${ED}"/usr/share/doc/${PF}/examples || die
fi
-
- if ! use zsh-completion; then
- rm -r "${ED}"/usr/share/zsh || die
- fi
}