summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/openbox/openbox-9999.ebuild')
-rw-r--r--x11-wm/openbox/openbox-9999.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/x11-wm/openbox/openbox-9999.ebuild b/x11-wm/openbox/openbox-9999.ebuild
index 1a98e9183a69..f38bbd651971 100644
--- a/x11-wm/openbox/openbox-9999.ebuild
+++ b/x11-wm/openbox/openbox-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
PYTHON_COMPAT=( python2_7 )
inherit multilib autotools python-r1 eutils
@@ -13,8 +13,6 @@ if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://git.openbox.org/dana/openbox"
SRC_URI="branding? (
https://dev.gentoo.org/~hwoarang/distfiles/surreal-gentoo.tar.gz )"
- KEYWORDS=""
-
else
SRC_URI="http://openbox.org/dist/openbox/${P}.tar.gz
branding? ( https://dev.gentoo.org/~hwoarang/distfiles/surreal-gentoo.tar.gz )"
@@ -51,14 +49,15 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
x11-base/xorg-proto"
+PATCHES=( "${FILESDIR}/${PN}-3.5.2-gnome-session.patch" )
+
src_prepare() {
use xdg && python_export_best
- epatch "${FILESDIR}"/${PN}-3.5.2-gnome-session.patch
+ default
sed -i \
-e "s:-O0 -ggdb ::" \
-e 's/-fno-strict-aliasing//' \
"${S}"/m4/openbox.m4 || die
- epatch_user
eautoreconf
}