summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.2.ebuild')
-rw-r--r--xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.2.ebuild b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.2.ebuild
new file mode 100644
index 000000000000..358163adf179
--- /dev/null
+++ b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A panel plugin that uses indicator-applet to show new messages"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-indicator-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libindicator-12.10.1:3
+ >=x11-libs/gtk+-3.6:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.11[gtk3(+)]
+ >=xfce-base/libxfce4util-4.11
+ >=xfce-base/xfce4-panel-4.11
+ >=xfce-base/xfconf-4.10"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # TODO: libido3-13.10.0 needs ubuntu-private.h from Ubuntu's GTK+ 3.x
+ XFCONF=(
+ --disable-ido
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+}