summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-time-out-plugin')
-rw-r--r--xfce-extra/xfce4-time-out-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-time-out-plugin/Manifest b/xfce-extra/xfce4-time-out-plugin/Manifest
index 1fe2bd3dc5bc..0ff5892a1f51 100644
--- a/xfce-extra/xfce4-time-out-plugin/Manifest
+++ b/xfce-extra/xfce4-time-out-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-time-out-plugin-1.1.3.tar.bz2 407981 BLAKE2B 4dd2e7ecd4bad79d0e16d94ee5f5f616477a5f0cd0a6eb29612bd2bc35e92d57aa05781c28b1257f50b0f3eb53bef20a3a6d6658b2657a356aa452a097e6b7f1 SHA512 1abb5b8efa985b08968c49bb01a6efd49bc43f16f4b80f892086643444979dab3b7819d7f7e51e4c898c92387c213684b0c28765624c1f04303c0674c5b91930
+DIST xfce4-time-out-plugin-1.1.4.tar.bz2 474667 BLAKE2B 8d331bcf44d226e4a264528c393c74c674c021646f95efeedb73368064639b23a5c3be9308fcacef579ca2a226857dbe14649ab212b85afe555bb14bdc8175a7 SHA512 c856caeff98170cb6461ead744377b13306dd5af60c8840679931ecba02861eaa929b63cc47bcc04ac115f7d88f711c9593dbbf60ceb6738b78f34c629ae06f0
diff --git a/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.4.ebuild b/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.4.ebuild
new file mode 100644
index 000000000000..b0756ee9d2eb
--- /dev/null
+++ b/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in to take periodical breaks from the computer"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-time-out-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-time-out-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=x11-libs/libX11-1.6.7
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}