summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-wavelan-plugin')
-rw-r--r--xfce-extra/xfce4-wavelan-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-wavelan-plugin/files/xfce4-wavelan-plugin-0.6.2-close-definition.patch55
-rw-r--r--xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.3.ebuild (renamed from xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.2-r1.ebuild)21
3 files changed, 12 insertions, 66 deletions
diff --git a/xfce-extra/xfce4-wavelan-plugin/Manifest b/xfce-extra/xfce4-wavelan-plugin/Manifest
index c4695c8c1311..62f363b21448 100644
--- a/xfce-extra/xfce4-wavelan-plugin/Manifest
+++ b/xfce-extra/xfce4-wavelan-plugin/Manifest
@@ -1 +1 @@
-DIST xfce4-wavelan-plugin-0.6.2.tar.bz2 356954 BLAKE2B 982ffbc5f72d5771650b4e8d6c64f468bf927febca8c65d8a20258043e1c9433ee9c4631eb501e620f6a1037852494e3f66fe2700e08063ee770cedcad857475 SHA512 90e0d5f2e9add1f177f0f69e537ccdeeaf518a122feb776cb8bce139b9af6ea7d248e758ae381b69041bbdefe2d38f2162d08b25fd246d98c3a028d743892123
+DIST xfce4-wavelan-plugin-0.6.3.tar.bz2 364789 BLAKE2B 3d39eb0716efaccd8effd6f6a89da9e0f749cbffdf2bdebeb021ebd8ed9c8f3f5eb728db8ebacf52cc977db827d9b0536c9c42a94caa40469172fce800fc71ef SHA512 a49af2c59f59890790081525a793638c673446b4a3f77584013cf87201fc0cf3218622834c32918daeb3fd2d87511db19512b903c60f8ccd58ae5c4f78507b7a
diff --git a/xfce-extra/xfce4-wavelan-plugin/files/xfce4-wavelan-plugin-0.6.2-close-definition.patch b/xfce-extra/xfce4-wavelan-plugin/files/xfce4-wavelan-plugin-0.6.2-close-definition.patch
deleted file mode 100644
index bc27e2c12afc..000000000000
--- a/xfce-extra/xfce4-wavelan-plugin/files/xfce4-wavelan-plugin-0.6.2-close-definition.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-https://gitlab.xfce.org/panel-plugins/xfce4-wavelan-plugin/-/merge_requests/4
-https://bugs.gentoo.org/799827
-
-From: Olaf Hering <olaf@aepfle.de>
-Date: Fri, 25 Jun 2021 19:37:09 +0200
-Subject: [PATCH] remove bogus close function
-
-Just close the file descriptor, instead of doing shutdown.
-
-Not doing so was already wrong in 2006.
-
-wi_linux.c:83:1: error: conflicting types for 'close'
- close(int fd)
- ^~~~~
-In file included from /usr/include/glib-2.0/gio/gcredentials.h:32:0,
- from /usr/include/glib-2.0/gio/gio.h:46,
- from /usr/include/xfce4/libxfce4util/xfce-gio-extensions.h:28,
- from /usr/include/xfce4/libxfce4util/libxfce4util.h:40,
- from wi_linux.c:32:
-/usr/include/unistd.h:353:12: note: previous declaration of 'close' was here
- extern int close (int __fd);
- ^~~~~
-make[2]: *** [Makefile:525: libwavelan_la-wi_linux.lo] Error 1
-make[2]: Leaving directory '/home/abuild/rpmbuild/BUILD/xfce4-wavelan-plugin-20210505T194034.7ba466b/panel-plugin'
-
-Signed-off-by: Olaf Hering <olaf@aepfle.de>
---- a/panel-plugin/wi_linux.c
-+++ b/panel-plugin/wi_linux.c
-@@ -31,6 +31,7 @@
-
- #include <libxfce4util/libxfce4util.h>
-
-+#include <unistd.h>
- #include <math.h>
- #include <stdio.h>
- #include <stdlib.h>
-@@ -79,17 +80,9 @@ wi_open(const char *interface)
- return(device);
- }
-
--static void
--close(int fd)
--{
-- shutdown(fd, SHUT_RDWR);
--}
--
- void
- wi_close(struct wi_device *device)
- {
-- g_return_if_fail(device != NULL);
--
- close(device->socket);
- g_free(device);
- }
-GitLab
diff --git a/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.2-r1.ebuild b/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.3.ebuild
index 9ea3c7fb7cdd..ea587e91560f 100644
--- a/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.2-r1.ebuild
+++ b/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.3.ebuild
@@ -9,20 +9,21 @@ SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86"
+KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv x86"
-DEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
- >=xfce-base/xfce4-panel-4.12:="
-RDEPEND="${DEPEND}
- kernel_linux? ( sys-apps/net-tools )"
+DEPEND="
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:=
+"
+RDEPEND="
+ ${DEPEND}
+ kernel_linux? ( sys-apps/net-tools )
+"
BDEPEND="
dev-util/intltool
sys-devel/gettext
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${P}-close-definition.patch
-)
+ virtual/pkgconfig
+"
src_install() {
default