summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild45
-rw-r--r--xfce-extra/xfce4-notifyd/Manifest2
-rw-r--r--xfce-extra/xfce4-notifyd/xfce4-notifyd-0.9.6.ebuild (renamed from xfce-extra/xfce4-notifyd/xfce4-notifyd-0.9.4.ebuild)0
-rw-r--r--xfce-extra/xfce4-panel-profiles/Manifest1
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild53
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild3
-rw-r--r--xfce-extra/xfce4-screenshooter/Manifest2
-rw-r--r--xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.11.0.ebuild77
-rw-r--r--xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.11.1.ebuild76
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.2-r1.ebuild (renamed from xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.2.ebuild)23
-rw-r--r--xfce-extra/xfce4-verve-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.3.ebuild (renamed from xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.1.ebuild)34
12 files changed, 235 insertions, 83 deletions
diff --git a/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild b/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..86ce50462069
--- /dev/null
+++ b/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Show the status of the IBM Hard Drive Active Protection System"
+HOMEPAGE="https://michael.orlitzky.com/code/xfce4-hdaps.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.xz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+DEPEND="
+ >=x11-libs/gtk+-3.20:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+"
+RDEPEND="
+ ${DEPEND}
+ app-laptop/hdapsd
+ app-laptop/tp_smapi
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/xfce-extra/xfce4-notifyd/Manifest b/xfce-extra/xfce4-notifyd/Manifest
index ab53fbfd909e..1831edd6faf2 100644
--- a/xfce-extra/xfce4-notifyd/Manifest
+++ b/xfce-extra/xfce4-notifyd/Manifest
@@ -1 +1 @@
-DIST xfce4-notifyd-0.9.4.tar.bz2 732160 BLAKE2B d0c47875acf638f44ae8188c7a39f1785a9e3c489f4fad209e9c591780a91b0439037a0c62351619f71d2765dacf11a786d5678c03ec846f4aa0a0bc0b823166 SHA512 d3339ec3555f27e624e643b52ce4de2a0834d38f675b286976abcb4e143cbbb32665b1f36fbff23791c152e1f0616b752a7f049045fc32829c27c0a87d82df94
+DIST xfce4-notifyd-0.9.6.tar.bz2 742198 BLAKE2B 8bcd2df7e7b8727ba05f94577e3fe9a575c0801bccb841e4077f5150578f2b7faf25444193da45ddfef870d9cf470793b0c152b939f4391421fa226a39eca9f3 SHA512 deef625fdb7828ac25a3eeb2c5e5813f285310354b33a81e1c7943024d9dee9e9b5765f94f7e7ccedd1998dab77eb2c62a2803864d56aed6f831f08b910f0071
diff --git a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.9.4.ebuild b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.9.6.ebuild
index 0670bff5128f..0670bff5128f 100644
--- a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.9.4.ebuild
+++ b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.9.6.ebuild
diff --git a/xfce-extra/xfce4-panel-profiles/Manifest b/xfce-extra/xfce4-panel-profiles/Manifest
index a211a0320f5b..f35e422c03aa 100644
--- a/xfce-extra/xfce4-panel-profiles/Manifest
+++ b/xfce-extra/xfce4-panel-profiles/Manifest
@@ -1,2 +1 @@
-DIST xfce4-panel-profiles-1.0.13.tar.bz2 86671 BLAKE2B 0bf2d39aa2d7d21a99a9a7245e5de9e717b628f0eded2736db70cc87c4f6e1e1d10aecdc6586c43c6355747e68a2ceb1920d5309bf38ede07c1167c590dc116f SHA512 648324e5dd95ab0a513829d7d816e2113ae677d9ad6ac9b01d73c6b4105b54d5e773150d5440ad35a37b4dc75478f40a24e0223decf940f3cf658241547ce75a
DIST xfce4-panel-profiles-1.0.14.tar.bz2 101521 BLAKE2B 197ebba356e8d7661779531147b08454762a9b61beebd2323bc9e88b26381952c2caa58c6fb110680a5038fc19422852722d72dfde09addb68ec9424ecf16a23 SHA512 e316e9d4f0d27b16ce83a50adfe1a3fe2102b7f5c3ed9e9ceebf5968e265064b4d4ade1e0dbd84180758a9c1fa72d8df1fb4d06a631d07956ea8add0f66da984
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild
deleted file mode 100644
index 18b93a196b47..000000000000
--- a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit python-single-r1 xdg-utils
-
-DESCRIPTION="Simple application to manage Xfce panel layouts"
-HOMEPAGE="
- https://docs.xfce.org/apps/xfce4-panel-profiles/start
- https://gitlab.xfce.org/apps/xfce4-panel-profiles/
-"
-SRC_URI="
- https://archive.xfce.org/src/apps/xfce4-panel-profiles/$(ver_cut 1-2)/${P}.tar.bz2
-"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-BDEPEND="
- ${PYTHON_DEPS}
-"
-RDEPEND="
- ${BDEPEND}
- dev-libs/gobject-introspection
- $(python_gen_cond_dep '
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- ')
- x11-libs/gtk+:3[introspection]
- xfce-base/libxfce4ui[introspection]
- xfce-base/xfce4-panel
-"
-
-src_configure() {
- # home-made configure script, yay!
- ./configure \
- --prefix="${EPREFIX}/usr" \
- --python="${EPYTHON}" \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" || die
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild
index f7ba0bc11386..275e605f5c73 100644
--- a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild
+++ b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,7 +19,6 @@ SRC_URI="
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~riscv ~x86"
-IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
BDEPEND="
diff --git a/xfce-extra/xfce4-screenshooter/Manifest b/xfce-extra/xfce4-screenshooter/Manifest
index c23d4875dbe6..2a71d88e359d 100644
--- a/xfce-extra/xfce4-screenshooter/Manifest
+++ b/xfce-extra/xfce4-screenshooter/Manifest
@@ -1 +1,3 @@
DIST xfce4-screenshooter-1.10.6.tar.bz2 813187 BLAKE2B 2f5d12cd1879d35911fee159e909f8b64970831fdd350fd46ca64371376592d30db8658d03045cc84d52ce16c19ec374dcb926b0151fcfc35e365832eb3b8803 SHA512 2984ff3a64d0783c62ad5ac33ef54f4ec70fb6d06ac66f4a963940878d04b5e77c100a8121b73788ce6cc0af427fec9d5bf09235465b3591cd57cd16c7d9cda2
+DIST xfce4-screenshooter-1.11.0.tar.bz2 720373 BLAKE2B 8a6cf00a61be097a41222db42b887a97972013c3f93e0b969db5d0c1fc75a0f85a8b0f671b0047dba2198ad770045a608e078323d06b265a688efd700100cbf8 SHA512 afe7c97799c94e498b4304923d48ec195ebba776ecb626df55b4e5b091e53717d331a7513cde1095b1da5c1fac93fc52ab5a77c67ffbd71931c3bb4f5eb3dc64
+DIST xfce4-screenshooter-1.11.1.tar.bz2 721424 BLAKE2B 386e203b534993f93ffa6fc8c6d15dcbcefd79ca1c133a61ff157b406d96cef30da58bb6dcc069fd7e1d9911a256adaaa4fa01541ab07d61f683f1f603f73477 SHA512 aee31311faea2bb08d5e29722da190b0c7e2b37948a688a49212cd57cc4efc3f43b3c1588d9326f97eb174771412c60707cc88ae2ee0596546e9750a06112588
diff --git a/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.11.0.ebuild b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.11.0.ebuild
new file mode 100644
index 000000000000..4c573c68cd3c
--- /dev/null
+++ b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.11.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce4 screenshooter application and panel plugin"
+HOMEPAGE="
+ https://docs.xfce.org/apps/xfce4-screenshooter/start
+ https://gitlab.xfce.org/apps/xfce4-screenshooter/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="X wayland"
+REQUIRED_USE="|| ( X wayland )"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gdk-pixbuf-2.16
+ >=x11-libs/gtk+-3.24.0:3[X?,wayland?]
+ >=x11-libs/pango-1.44.0
+ dev-libs/libxml2
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+ >=xfce-base/libxfce4util-4.16.0:=
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/xfconf-4.16.0:=
+ wayland? (
+ dev-libs/wayland
+ )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ >=x11-libs/libXi-1.7.8
+ x11-libs/libXtst
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/glib-utils
+ sys-apps/help2man
+ sys-devel/gettext
+ virtual/pkgconfig
+ wayland? (
+ dev-util/wayland-scanner
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable X x11)
+ $(use_enable X libxtst)
+ $(use_enable wayland)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.11.1.ebuild b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.11.1.ebuild
new file mode 100644
index 000000000000..da6096ccff2c
--- /dev/null
+++ b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.11.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce4 screenshooter application and panel plugin"
+HOMEPAGE="
+ https://docs.xfce.org/apps/xfce4-screenshooter/start
+ https://gitlab.xfce.org/apps/xfce4-screenshooter/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~ia64 ~loong ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="X wayland"
+REQUIRED_USE="|| ( X wayland )"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gdk-pixbuf-2.16
+ >=x11-libs/gtk+-3.24.0:3[X?,wayland?]
+ >=x11-libs/pango-1.44.0
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+ >=xfce-base/libxfce4util-4.16.0:=
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/xfconf-4.16.0:=
+ wayland? (
+ dev-libs/wayland
+ )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ >=x11-libs/libXi-1.7.8
+ x11-libs/libXtst
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/glib-utils
+ sys-apps/help2man
+ sys-devel/gettext
+ virtual/pkgconfig
+ wayland? (
+ dev-util/wayland-scanner
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable X x11)
+ $(use_enable X libxtst)
+ $(use_enable wayland)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.2.ebuild b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.2-r1.ebuild
index 6c8b64574095..c7dfdd90e84e 100644
--- a/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.2.ebuild
+++ b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.2-r1.ebuild
@@ -1,24 +1,31 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Smart bookmark plug-in for the Xfce desktop environment"
-HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin"
+HOMEPAGE="
+ https://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin/
+ https://gitlab.xfce.org/panel-plugins/xfce4-smartbookmark-plugin/
+"
SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-RDEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
- >=xfce-base/xfce4-panel-4.12:="
-DEPEND="${RDEPEND}"
+DEPEND="
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:=
+"
+RDEPEND="
+ ${DEPEND}
+"
BDEPEND="
dev-util/intltool
sys-devel/gettext
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
src_prepare() {
# substitute default bugtracker
diff --git a/xfce-extra/xfce4-verve-plugin/Manifest b/xfce-extra/xfce4-verve-plugin/Manifest
index 155f56518f4b..b3acb087b687 100644
--- a/xfce-extra/xfce4-verve-plugin/Manifest
+++ b/xfce-extra/xfce4-verve-plugin/Manifest
@@ -1 +1 @@
-DIST xfce4-verve-plugin-2.0.1.tar.bz2 384412 BLAKE2B 3a0370b1027fef00d748de43bf420271e8d093a203a1c77dfbb8ecd093e139d35ce6f7d585558635b2f5566dc49d8c226c9d6ebe88e7a785ffeabe1a9c8f63eb SHA512 c8397bd833e2a2cf25d86bd9234bdbafed00ce0783273532a57e87a5182d26b3e84b402ed8c9fd9204d5d46fbca257fcf6601f279d9929d806a4c36338379876
+DIST xfce4-verve-plugin-2.0.3.tar.bz2 383536 BLAKE2B 42202d50d3c8533658b096d5a8b6347d71bf82dd3b30d61d3adaaf313d53047d0bd78a6195f18205b095f088ba08a7411a1a9493637a0ffcc5acafdbbd9dbcc9 SHA512 acfa0c9ee19904a0cbb5118bbb3324499a6fcfbf881478bfb745e0675be89aacb4ccd23137ba78fab0fe77e2e4b67a0c815cb3f37ee8132ebc09aecf9aaf1d1e
diff --git a/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.1.ebuild b/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.3.ebuild
index 595178f2a348..268449bdd8fc 100644
--- a/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.1.ebuild
+++ b/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.3.ebuild
@@ -1,32 +1,32 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="A comfortable command line plugin for the Xfce panel"
-HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-verve-plugin"
+HOMEPAGE="
+ https://goodies.xfce.org/projects/panel-plugins/xfce4-verve-plugin/
+ https://gitlab.xfce.org/panel-plugins/xfce4-verve-plugin/
+"
SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-RDEPEND=">=xfce-base/libxfce4ui-4.12:=
+DEPEND="
+ dev-libs/glib:2
+ >=dev-libs/libpcre-5:=
+ >=xfce-base/libxfce4ui-4.12:=
>=xfce-base/xfce4-panel-4.12:=
- dev-libs/glib:2=
- >=dev-libs/libpcre-5:="
-DEPEND="${RDEPEND}"
+"
+RDEPEND="
+ ${DEPEND}
+"
BDEPEND="
dev-util/intltool
- virtual/pkgconfig"
-
-src_configure() {
- local myconf=(
- --libexecdir="${EPREFIX}"/usr/$(get_libdir)
- )
- econf "${myconf[@]}"
-}
+ virtual/pkgconfig
+"
src_install() {
default